Bug 1661978 - Using OLM to install asb, asb image tag in dc is incorrect
Summary: Using OLM to install asb, asb image tag in dc is incorrect
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: jkim
QA Contact: Zihan Tang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-25 05:53 UTC by Zihan Tang
Modified: 2019-06-04 10:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:33 UTC

Description Zihan Tang 2018-12-25 05:53:29 UTC
Description of problem:
Using OLM to install asb, after installation, the image tag is incorrect.
There are two problems in here:
1. Image (origin-ansible-service-broker) in dc of asb is 3.11, but in the csv the image tag is latest. The image in dc and csv should keep the same.
2. Image origin-ansible-service-broker and automation-broker-operator should exist 4.0 tag in upstream, and should use 4.0 as default in csv

Version-Release number of selected component (if applicable):
installer: 0.8.0
OLM version: 0.8.0  git commit: 66be86a
ASB operator: docker.io/automationbroker/automation-broker-operator:latest

How reproducible:
always

Steps to Reproduce:
1. install asb by operator:
# oc create -f https://raw.githubusercontent.com/fusor/catbrokers4/master/files/asb/01-asb-catalogsource-configmap.yaml
# oc create -f https://raw.githubusercontent.com/fusor/catbrokers4/master/files/asb/02-asb-catalogsource.yaml

# oc create namespace automation-broker
# oc create clusterrolebinding automation-broker-admin --clusterrole=admin --serviceaccount=automation-broker:automation-broker
# oc create -f https://raw.githubusercontent.com/fusor/catbrokers4/master/files/asb/03-asb-operatorgroup.yaml
# oc create -f https://raw.githubusercontent.com/fusor/catbrokers4/master/files/asb/04-asb-subscription.yaml
# oc create -f https://raw.githubusercontent.com/fusor/catbrokers4/master/files/asb/05-asb-cr.yaml

asb install successfully.

2. check csv 
# oc get csv automationbrokeroperator.v0.1.0 -o yaml
....
      deployments:
      - name: automation-broker-operator
        spec:
          replicas: 1
          selector:
            matchLabels:
              name: automation-broker-operator-alm-owned
          template:
            metadata:
              labels:
                name: automation-broker-operator-alm-owned
              name: automation-broker-operator-alm-owned
            spec:
              containers:
              - env:
                - name: IMAGE
                  value: docker.io/ansibleplaybookbundle/origin-ansible-service-broker:latest
                - name: WATCH_NAMESPACE
                  valueFrom:
                    fieldRef:
                      fieldPath: metadata.namespace
                image: docker.io/automationbroker/automation-broker-operator:latest
                imagePullPolicy: IfNotPresent
                name: automation-broker-operator
              serviceAccountName: automation-broker-operator
....
3. check asb image
# oc get pod -o yaml | grep image
      image: docker.io/ansibleplaybookbundle/origin-ansible-service-broker:v3.11
      imagePullPolicy: IfNotPresent
      image: docker.io/ansibleplaybookbundle/origin-ansible-service-broker:v3.11
      imagePullPolicy: IfNotPresent
# oc exec automation-broker-1-jrmbj -c broker -- /usr/bin/asbd --version
1.3.20

Actual results:
asb image is 3.11

Expected results:
asb image should be the same as csv, and 4.0 image.

Additional info:
workaround: 
docker.io/ansibleplaybookbundle/origin-ansible-service-broker:canary is 4.0 image, we use it temporarily as workaround.
1. change csv origin-ansible-service-broker:latest to    origin-ansible-service-broker:canary
2. change asb dc to use origin-ansible-service-broker:canary

Comment 3 Zihan Tang 2019-02-26 08:47:20 UTC
Verified
Cluster version is 4.0.0-0.nightly-2019-02-25-234632

$ oc get pod -o yaml | grep image
      image: docker.io/ansibleplaybookbundle/origin-ansible-service-broker:v4.0
      imagePullPolicy: IfNotPresent
      image: docker.io/ansibleplaybookbundle/origin-ansible-service-broker:v4.0
      imagePullPolicy: IfNotPresent
  .....
      image: docker.io/automationbroker/automation-broker-operator:v4.0
      imageID: docker.io/automationbroker/automation-broker-operator@sha256:e988379d4436fd64a11117de20f3f2770acf4fe0d5658d353701cc9e34a48806

Comment 6 errata-xmlrpc 2019-06-04 10:41:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.