Bug 1662033 - xorg-x11-drv-amdgpu not updated in rawhide
Summary: xorg-x11-drv-amdgpu not updated in rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-amdgpu
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christopher Atherton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-25 11:15 UTC by Steve
Modified: 2018-12-26 18:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-26 18:55:20 UTC
Type: Bug


Attachments (Terms of Use)

Description Steve 2018-12-25 11:15:38 UTC
Description of problem:
xorg-x11-drv-amdgpu is not being updated in rawhide.

From a rawhide install in a VM:

# dnf -q repoquery xorg-x11-drv-amdgpu
xorg-x11-drv-amdgpu-0:18.0.1-4.fc29.x86_64

However, the F29 "fedora" repo has a newer version:

# dnf -q repoquery --enablerepo=fedora --releasever=29 xorg-x11-drv-amdgpu
xorg-x11-drv-amdgpu-0:18.0.1-4.fc29.x86_64
xorg-x11-drv-amdgpu-0:18.1.0-1.fc29.x86_64

Also, this returns no results:

https://apps.fedoraproject.org/packages/s/xorg-x11-drv-amdgpu

Comment 1 Steve 2018-12-25 16:35:09 UTC
Here is a more informative test:

# dnf -q list --enablerepo=fedora --releasever=29 --showduplicates xorg-x11-drv-amdgpu
Installed Packages
xorg-x11-drv-amdgpu.x86_64                18.0.1-4.fc29                 @rawhide
Available Packages
xorg-x11-drv-amdgpu.x86_64                18.0.1-4.fc29                 @rawhide
xorg-x11-drv-amdgpu.x86_64                18.0.1-4.fc29                 rawhide 
xorg-x11-drv-amdgpu.x86_64                18.1.0-1.fc29                 fedora  

In contrast, the "-ati" package is newer in rawhide:

# dnf -q list --enablerepo=fedora --releasever=29 --showduplicates xorg-x11-drv-ati
Installed Packages
xorg-x11-drv-ati.x86_64                  18.1.0-1.fc30                  @rawhide
Available Packages
xorg-x11-drv-ati.x86_64                  18.0.1-2.fc29                  fedora  
xorg-x11-drv-ati.x86_64                  18.1.0-1.fc30                  @rawhide
xorg-x11-drv-ati.x86_64                  18.1.0-1.fc30                  rawhide 

Further, this returns a result:

https://apps.fedoraproject.org/packages/s/xorg-x11-drv-ati

Comment 2 Steve 2018-12-25 17:14:31 UTC
The problem is that there are no rawhide builds for xorg-x11-drv-amdgpu:

https://koji.fedoraproject.org/koji/packageinfo?packageID=23073

Compare with xorg-x11-drv-ati:

https://koji.fedoraproject.org/koji/packageinfo?packageID=95

Comment 3 Steve 2018-12-25 17:44:37 UTC
Here is another difference:

xorg-x11-drv-amdgpu is not required by any other packages:

# dnf -q repoquery --whatrequires xorg-x11-drv-amdgpu

In contrast, xorg-x11-drv-ati is required by xorg-x11-drivers:

# dnf -q repoquery --whatrequires xorg-x11-drv-ati
xorg-x11-drivers-0:7.7-23.fc29.x86_64

# dnf -q info xorg-x11-drivers
Available Packages
Name         : xorg-x11-drivers
Version      : 7.7
Release      : 23.fc29
Arch         : x86_64
Size         : 7.6 k
Source       : xorg-x11-drivers-7.7-23.fc29.src.rpm
Repo         : rawhide
Summary      : X.Org X11 driver installation package
License      : MIT
Description  : The purpose of this package is to require all of the individual X.Org
             : driver rpms, to allow the OS installation software to install all drivers
             : all at once, without having to track which individual drivers are present
             : on each architecture.  By installing this package, it forces all of the
             : individual driver packages to be installed.

Comment 4 Christopher Atherton 2018-12-25 23:56:01 UTC
xorg-x11-drv-amdgpu is now built for rawhide.

Comment 5 Steve 2018-12-26 01:13:12 UTC
(In reply to Christopher Atherton from comment #4)
> xorg-x11-drv-amdgpu is now built for rawhide.

Thanks, Christopher.

This now returns a result:
https://apps.fedoraproject.org/packages/s/xorg-x11-drv-amdgpu

Comment 6 Steve 2018-12-26 01:33:33 UTC
Bug 1662073 - xorg-x11-drv-amdgpu not required by xorg-x11-drivers

Comment 7 Steve 2018-12-26 18:55:20 UTC
Successfully updated from rawhide repo:

# dnf -q list xorg-x11-drv-amdgpu
Installed Packages
xorg-x11-drv-amdgpu.x86_64                18.1.0-1.fc30                @rawhide

Thank-you.

Closing.


Note You need to log in before you can comment on or make changes to this bug.