Bug 1662119 - Installer did not create expected cluster according to customized Manifests files
Summary: Installer did not create expected cluster according to customized Manifests f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Matthew Staebler
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-26 09:26 UTC by liujia
Modified: 2019-06-04 10:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:36 UTC

Description liujia 2018-12-26 09:26:32 UTC
Description of problem:
The customized items defined in Manifests files by users did not take effect when create cluster with existed customized Manifests.

Changes made to Manifests files:
1. 
[root@preserve-installer 080]# cat demo/manifests/cvo-overrides.yaml|grep channel
  channel: stable

2.
[root@preserve-installer 080]# cat demo/openshift/99_openshift-cluster-api_master-machines.yaml|grep Zone
          availabilityZone: us-east-1b

After creating cluster succeed, checked above items.
1.   spec:
    channel: fast
    clusterID: 7d36c092-b49f-479a-9235-a60a70fca737
    upstream: http://localhost:8080/graph

2. Master was in zone us-east-1a

Version-Release number of the following components:
# ./openshift-install version
./openshift-install v0.8.0

How reproducible:
always

Steps to Reproduce:
1.Run "./openshift-install create manifests  --dir demo" to generate default Manifests files. 
# ls -la demo/
total 224
drwxr-xr-x. 4 root root   4096 Dec 26 08:31 .
drwxr-xr-x. 3 root root   4096 Dec 26 08:28 ..
drwxr-xr-x. 2 root root   4096 Dec 26 08:31 manifests
drwxr-xr-x. 2 root root   4096 Dec 26 08:31 openshift
2. Edit cvo-overrides.yaml and 99_openshift-cluster-api_master-machines.yaml
3. Run "./openshift-install create cluster --dir demo" to create cluster with above customized manifests

Actual results:
Customized items did not take effect.

Expected results:
User can create expected cluster with customized manifests. 

Additional info:

Comment 1 W. Trevor King 2019-01-13 00:50:25 UTC
[1] will fix this.  I'd hoped to land it this week, but there was a lot of install-config churn and it slipped through.

[1]: https://github.com/openshift/installer/pulls/wking

Comment 2 W. Trevor King 2019-01-14 14:06:24 UTC
Oops, I'd meant to link https://github.com/openshift/installer/pull/792

Comment 3 Matthew Staebler 2019-01-17 19:29:06 UTC
https://github.com/openshift/installer/pull/890 fixes preserving changes to the manifests.

Comment 4 Matthew Staebler 2019-01-23 19:40:27 UTC
https://github.com/openshift/installer/pull/1121 fixes specifying the availability zone to use for masters.

Comment 5 Matthew Staebler 2019-02-12 17:21:22 UTC
https://github.com/openshift/installer/pull/1211 fixes panic when reading in the master machines manifest file in later stages.

Comment 6 W. Trevor King 2019-02-27 06:10:23 UTC
Some of these changes went out in v0.13.0 [1], but [2] is still in flight.

[1]: https://github.com/openshift/installer/releases/tag/v0.13.0
[2]: https://github.com/openshift/installer/pull/1121

Comment 7 W. Trevor King 2019-02-28 10:02:44 UTC
https://github.com/openshift/installer/pull/1121 just landed and will go out in the next release.

Comment 9 Qin Ping 2019-03-11 02:41:23 UTC
verified with:
$ ./openshift-install version
./openshift-install v4.0.21-1-dirty

Comment 12 errata-xmlrpc 2019-06-04 10:41:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.