Bug 1662135 - Kuryr controller crashes after stopping and starting the neutron_api container
Summary: Kuryr controller crashes after stopping and starting the neutron_api container
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-kuryr-kubernetes
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Antoni Segura Puimedon
QA Contact: GenadiC
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-26 10:52 UTC by Itzik Brown
Modified: 2019-01-03 08:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-03 08:40:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Itzik Brown 2018-12-26 10:52:16 UTC
Description of problem:
After stopping the neutron_api container and then starting it again the kuryr controller crashes and doesn't move to a ready state.

Version-Release number of selected component (if applicable):
OSP13 2018-12-13.4
OCP3.11 v3.11.61

How reproducible:


Steps to Reproduce:
1.As described 
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Itzik Brown 2018-12-26 11:23:28 UTC
After deleting the Kuryr controller a new one is created and moving to a ready state.

Comment 2 Itzik Brown 2019-01-03 08:40:23 UTC
I'm closing this one.
After about 2 minutes since the Neutron server starts - the Kuryr controller moves to a ready state.


Note You need to log in before you can comment on or make changes to this bug.