Bug 1662165 - Regression in iwl7260-firmware-25.30.13.0-89.fc29, Intel Corporation Wireless 8265 / 8275, connection failed
Summary: Regression in iwl7260-firmware-25.30.13.0-89.fc29, Intel Corporation Wireless...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: linux-firmware
Version: 30
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-26 15:59 UTC by Vladislav Grigoryev
Modified: 2019-08-25 16:29 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-25 16:29:01 UTC


Attachments (Terms of Use)

Description Vladislav Grigoryev 2018-12-26 15:59:37 UTC
Description of problem:
Upgrading iwl7260-firmware to version 25.30.13.0-89.fc29 result in failure to establish network connection on Intel Corporation Wireless 8265 / 8275 [8086:24fd] (rev 78).
This is regression because downgrading to previous version 25.30.13.0-87 solves the issue.

Version-Release number of selected component (if applicable):
iwl7260-firmware-25.30.13.0-89.fc29.noarch

How reproducible:
Always.

Steps to Reproduce:
1. dnf update iwl7260-firmware
2. rmmod iwlmvm iwlwifi
3. modprobe iwlwifi

Actual results:
$ nmcli connection up wifi
Error: Connection activation failed: The Wi-Fi network could not be found

Hardware:
02:00.0 Network controller [0280]: Intel Corporation Wireless 8265 / 8275 [8086:24fd] (rev 78)
	Subsystem: Intel Corporation Dual Band Wireless-AC 8265 [8086:1010]
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi

Logs:
NetworkManager[790]: <info>  [1545834611.5527] device (wlp2s0): supplicant interface state: disconnected -> scanning
NetworkManager[790]: <warn>  [1545834636.5428] device (wlp2s0): Activation: (wifi) association took too long, failing activation

Comment 1 MartinG 2019-08-07 06:44:58 UTC
This hit me on a Dell Precision 5530 on Fedora 30 now.

Hardware:
Network controller: Intel Corporation Wireless-AC 9260 (rev 29)

Error:
iwlwifi 0000:3b:00.0: FW error in SYNC CMD GEO_TX_POWER_LIMIT

Faulty firmware:
iwl7260-firmware-25.30.13.0-99.fc30.noarch

Workaround:
sudo dnf downgrade -y iwl7260-firmware
sudo rmmod iwlmvm iwlwifi
sudo modprobe iwlwifi

Working firmware:
iwl7260-firmware-25.30.13.0-94.fc30.noarch

Comment 2 Vladislav Grigoryev 2019-08-16 06:31:24 UTC
Even after updating to Fedora 30, WiFi is almost unusable.
Sometimes it manages to connect once in ~10 attempts but the connection is very unstable.

The last stable version for me is still 25.30.13.0-87.

This workaround is the only way to get stable WiFi:
```
sudo dnf install "https://dl.fedoraproject.org/pub/fedora/linux/releases/29/Everything/x86_64/os/Packages/i/iwl7260-firmware-25.30.13.0-87.fc29.noarch.rpm"
sudo dnf versionlock add iwl7260-firmware
sudo rmmod iwlmvm iwlwifi
sudo modprobe iwlwifi
```

Comment 3 Vladislav Grigoryev 2019-08-17 02:39:16 UTC
A guaranteed way to reproduce the issue is to make the SSID hidden.
This way it can't find the network no matter how many connection attempts I make.
But as soon as I downgrade to the version 25.30.13.0-87, it connects and works fine.

Comment 4 Vladislav Grigoryev 2019-08-25 16:29:01 UTC
It seems resolved with the latest update and power cycle:
iwl7260-firmware-25.30.13.0-101.fc30.noarch


Note You need to log in before you can comment on or make changes to this bug.