Bug 1662175 - Segfault in freeipa/krb5_child after upgrading to Fedora 29
Summary: Segfault in freeipa/krb5_child after upgrading to Fedora 29
Keywords:
Status: CLOSED DUPLICATE of bug 1622760
Alias: None
Product: Fedora
Classification: Fedora
Component: krb5
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Robbie Harwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-26 18:13 UTC by Patrick Dung
Modified: 2018-12-29 21:31 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-29 21:31:20 UTC
Type: Bug


Attachments (Terms of Use)

Description Patrick Dung 2018-12-26 18:13:29 UTC
Description of problem:
FreeIPA server not working after upgrade to Fedora 29. If you try to su to an FreeIPA user with the correct password, krb5_child segfaults.

Version-Release number of selected component (if applicable):
Fedora 29

freeipa-client-4.7.2-1.fc29.x86_64
freeipa-client-common-4.7.2-1.fc29.noarch
freeipa-common-4.7.2-1.fc29.noarch
freeipa-server-4.7.2-1.fc29.x86_64
freeipa-server-common-4.7.2-1.fc29.noarch
krb5-devel-1.16.1-22.fc29.x86_64
krb5-libs-1.16.1-22.fc29.i686
krb5-libs-1.16.1-22.fc29.x86_64
krb5-pkinit-1.16.1-22.fc29.x86_64
krb5-server-1.16.1-22.fc29.x86_64
krb5-workstation-1.16.1-22.fc29.x86_64
pam_krb5-2.4.13-11.fc29.x86_64
sssd-krb5-2.0.0-5.fc29.x86_64
sssd-krb5-common-2.0.0-5.fc29.x86_64

How reproducible:
Always

Steps to Reproduce:
Dec 27 02:00:05 server1 kernel: [ 2551.272984] krb5_child[25058]: segfault at 6e ip 00007f58ae29464e sp 00007fffb5047bf0 error 4 in libkrb5.so.3.3[7f58ae26b000+71000]
Dec 27 02:00:05 server1 kernel: [ 2551.273449] Code: fc bf 28 00 00 00 55 53 48 83 ec 18 64 48 8b 04 25 28 00 00 00 48 89 44 24 08 31 c0 e8 2b 9b fd ff 48 85 c0 0f 84 02 01 00 00 <f3> 41 0f 6f 07 f3 41 0f 6f 4f 10 48 89 c3 49 63 7f 20 0f 11 00 0f
Dec 27 02:00:05 server1 kernel: [ 2551.272984] krb5_child[25058]: segfault at 6e ip 00007f58ae29464e sp 00007fffb5047bf0 error 4 in libkrb5.so.3.3[7f58ae26b000+71000]
Dec 27 02:00:05 server1 kernel: [ 2551.273449] Code: fc bf 28 00 00 00 55 53 48 83 ec 18 64 48 8b 04 25 28 00 00 00 48 89 44 24 08 31 c0 e8 2b 9b fd ff 48 85 c0 0f 84 02 01 00 00 <f3> 41 0f 6f 07 f3 41 0f 6f 4f 10 48 89 c3 49 63 7f 20 0f 11 00 0f


Actual results:
It segfaults and authentication failed

Expected results:
It should not segfault

Additional info:

Comment 1 Matt Mossholder 2018-12-27 03:52:38 UTC
I just started getting this as well. It started sometime on 2018-12-25 or so.  Downgrading to krb5-libs-1.16.1-21 seems to resolve the issue.

Comment 2 Patrick Dung 2018-12-27 04:38:09 UTC
(In reply to Matt Mossholder from comment #1)
> I just started getting this as well. It started sometime on 2018-12-25 or
> so.  Downgrading to krb5-libs-1.16.1-21 seems to resolve the issue.

Yes, it works after downgrading. Thanks.

Comment 3 Alexander Bokovoy 2018-12-27 06:35:39 UTC
Since this is a crash in libkrb5, move to Kerberos. Also, original application showing the issue is SSSD, not FreeIPA.

Comment 4 Alexander Bokovoy 2018-12-29 21:31:20 UTC
Duplicate of bug 1622760.

*** This bug has been marked as a duplicate of bug 1622760 ***


Note You need to log in before you can comment on or make changes to this bug.