Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1662185 - [abrt] meld: isdir(): genericpath.py:42:isdir:TypeError: stat: path should be string, bytes, os.PathLike or integer, not NoneType
Summary: [abrt] meld: isdir(): genericpath.py:42:isdir:TypeError: stat: path should be...
Keywords:
Status: CLOSED DUPLICATE of bug 1721163
Alias: None
Product: Fedora
Classification: Fedora
Component: meld
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominic Hopf
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:800ad66da9911bd0cd2c2e90f87...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-26 20:43 UTC by Gabriele Svelto
Modified: 2019-10-07 22:23 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-07 22:23:31 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (613 bytes, text/plain)
2018-12-26 20:43 UTC, Gabriele Svelto
no flags Details
File: cgroup (349 bytes, text/plain)
2018-12-26 20:43 UTC, Gabriele Svelto
no flags Details
File: cpuinfo (1.41 KB, text/plain)
2018-12-26 20:43 UTC, Gabriele Svelto
no flags Details
File: environ (3.92 KB, text/plain)
2018-12-26 20:43 UTC, Gabriele Svelto
no flags Details
File: mountinfo (4.45 KB, text/plain)
2018-12-26 20:43 UTC, Gabriele Svelto
no flags Details
File: namespaces (129 bytes, text/plain)
2018-12-26 20:43 UTC, Gabriele Svelto
no flags Details
File: open_fds (1.67 KB, text/plain)
2018-12-26 20:43 UTC, Gabriele Svelto
no flags Details

Description Gabriele Svelto 2018-12-26 20:43:02 UTC
Description of problem:
I was comparing two very large folders (Windows user directories) stored on two different NTFS partitions, one stored in the local hard drive and one on an external drive.

Version-Release number of selected component:
meld-3.19.1-1.fc29

Additional info:
reporter:       libreport-2.9.7
cmdline:        /usr/bin/python3 /usr/bin/meld Users/gsvelto/AppData/ ../Windows/Users/gsvelto/AppData/
crash_function: isdir
exception_type: TypeError
executable:     /usr/bin/meld
interpreter:    python3-3.7.1-4.fc29.x86_64
kernel:         4.19.10-300.fc29.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
genericpath.py:42:isdir:TypeError: stat: path should be string, bytes, os.PathLike or integer, not NoneType

Traceback (most recent call last):
  File "/usr/lib/python3.7/site-packages/meld/dirdiff.py", line 1085, in on_treeview_selection_changed
    it, pane, os_path)
  File "/usr/lib/python3.7/site-packages/meld/tree.py", line 124, in is_folder
    return icon == "folder" or os.path.isdir(path)
  File "/usr/lib64/python3.7/genericpath.py", line 42, in isdir
    st = os.stat(s)
TypeError: stat: path should be string, bytes, os.PathLike or integer, not NoneType

Local variables in innermost frame:
s: None

Comment 1 Gabriele Svelto 2018-12-26 20:43:05 UTC
Created attachment 1516940 [details]
File: backtrace

Comment 2 Gabriele Svelto 2018-12-26 20:43:06 UTC
Created attachment 1516941 [details]
File: cgroup

Comment 3 Gabriele Svelto 2018-12-26 20:43:07 UTC
Created attachment 1516942 [details]
File: cpuinfo

Comment 4 Gabriele Svelto 2018-12-26 20:43:09 UTC
Created attachment 1516943 [details]
File: environ

Comment 5 Gabriele Svelto 2018-12-26 20:43:10 UTC
Created attachment 1516944 [details]
File: mountinfo

Comment 6 Gabriele Svelto 2018-12-26 20:43:11 UTC
Created attachment 1516945 [details]
File: namespaces

Comment 7 Gabriele Svelto 2018-12-26 20:43:13 UTC
Created attachment 1516946 [details]
File: open_fds

Comment 8 Dominic Hopf 2019-10-07 22:23:31 UTC

*** This bug has been marked as a duplicate of bug 1721163 ***


Note You need to log in before you can comment on or make changes to this bug.