Bug 1662258 - [Next_gen_installer]RemovedManagementStateOnHold should be updated to PendingRemove in README.md for cluster-samples-operator repo
Summary: [Next_gen_installer]RemovedManagementStateOnHold should be updated to Pending...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 4.1.0
Assignee: Gabe Montero
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-27 08:35 UTC by wewang
Modified: 2019-06-04 10:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:36 UTC

Description wewang 2018-12-27 08:35:49 UTC
Description of problem:
RemovedManagementStateOnHold should be updated to PendingRemove in README.md  for cluster-samples-operator repo

Version-Release number of selected component (if applicable):
./openshift-install v0.8.0

How reproducible:
always

Steps to Reproduce:
1. Get samplesresource 
  oc get samplesresource -o yaml
    - lastTransitionTime: 2018-12-25T10:11:13Z
      lastUpdateTime: 2018-12-25T10:11:13Z
      status: "False"
      type: PendingRemove

2.In part of :https://github.com/openshift/cluster-samples-operator#conditions 
RemovedManagementStateOnHold should be  PendingRemove according to samplesresource
3.

Actual results:
In part of :https://github.com/openshift/cluster-samples-operator#conditions, RemovedManagementStateOnHold exists 

Expected results:
RemovedManagementStateOnHold should be updated to PendingRemove

Additional info:

Comment 1 wewang 2018-12-27 08:39:11 UTC
also should update ImportCredentialsExist to ImportCredentialsExists according to: https://github.com/openshift/cluster-samples-operator/blob/master/pkg/apis/samplesoperator/v1alpha1/types.go#L158 
and should update ImageChangesInProgress to ChangesInProgress according to :https://github.com/openshift/cluster-samples-operator/blob/master/pkg/apis/samplesoperator/v1alpha1/types.go#L172 
here's samplersource yaml:
    - x86
    conditions:
    - lastTransitionTime: 2018-12-25T10:11:41Z
      lastUpdateTime: 2018-12-25T10:11:41Z
      status: "True"
      type: SamplesExist
    - lastTransitionTime: 2018-12-25T10:11:13Z
      lastUpdateTime: 2018-12-25T10:11:13Z
      status: "False"
      type: ImportCredentialsExists
    - lastTransitionTime: 2018-12-27T02:44:35Z
      lastUpdateTime: 2018-12-27T02:44:35Z
      message: architecture x86 unsupported; only support x86_64 and ppc64le
      status: "False"
      type: ConfigurationValid
    - lastTransitionTime: 2018-12-27T02:17:46Z
      lastUpdateTime: 2018-12-27T02:17:46Z
      status: "False"
      type: ChangesInProgress
    - lastTransitionTime: 2018-12-25T10:11:13Z
      lastUpdateTime: 2018-12-25T10:11:13Z
      status: "False"
      type: PendingRemove

Comment 2 Gabe Montero 2019-01-08 20:44:07 UTC
@Ben - do we want to make at least these name changes QE is requesting?

I at least don't agree with the ones in https://bugzilla.redhat.com/show_bug.cgi?id=1662258#c1

But I could be convinced to do https://bugzilla.redhat.com/show_bug.cgi?id=1662258#c0

Comment 3 Ben Parees 2019-01-08 20:52:53 UTC
For comment 1 I vote for:
RemovedManagementStateOnHold -> RemovePending  (not PendingRemove)


For comment 2, fix the godoc here to be "ImportCredentialsExist" (drop the s) so it's consistent:
https://github.com/openshift/cluster-samples-operator/blob/85ee5a974ca897e4b31e637454256a29ed8fe006/pkg/apis/samplesoperator/v1alpha1/types.go#L177

The other one (ImageChangesInProgress) looks to be fine, perhaps it was fixed since this bug was opened:
https://github.com/openshift/cluster-samples-operator/blob/85ee5a974ca897e4b31e637454256a29ed8fe006/pkg/apis/samplesoperator/v1alpha1/types.go#L188

I think wewang's point was just to get the godoc+type names in sync, more than to prefer one vs the other.

Comment 4 Gabe Montero 2019-01-11 01:24:47 UTC
PR https://github.com/openshift/cluster-samples-operator/pull/78 is up

Comment 5 Gabe Montero 2019-01-11 14:26:55 UTC
PR has merged

Comment 6 wewang 2019-01-15 08:32:19 UTC
Thanks Gabe, now types are sync with  configs.samples.operator.openshift.io instance
oc get configs.samples.operator.openshift.io instance -o yaml
  conditions:
    type: ConfigurationValid
    type: ImageChangesInProgress
    type: SamplesExist
    type: ImportCredentialsExist
    type: RemovePending
    type: MigrationInProgress
    type: ImportImageErrorsExist

but README.md(https://github.com/openshift/cluster-samples-operator/#conditions) is not sync with configs.samples.operator.openshift.io instance, seems it's not readable

Comment 7 wewang 2019-01-16 02:13:45 UTC
@Gabe, I assigned it, In case you miss it, thx

Comment 8 Gabe Montero 2019-01-16 21:50:25 UTC
OK PR https://github.com/openshift/cluster-samples-operator/pull/80/files is adding in the ImportImageErrorsExist condition

MigrationInProgress is still omitted ... will add that back in after the other PRs merge.

Comment 9 Gabe Montero 2019-02-06 14:59:44 UTC
In all the churn there was still some minor tweaks to do

https://github.com/openshift/cluster-samples-operator/pull/91 addresses

Comment 10 Gabe Montero 2019-02-07 05:16:03 UTC
PR just merged

Comment 11 wewang 2019-02-15 03:33:31 UTC
Checked Overview in README.md in cluster-samples-operator,already updated,  so verified it.

Comment 12 Ben Parees 2019-02-19 04:49:26 UTC
reassigning to gmontero for bookkeeping.

Comment 16 errata-xmlrpc 2019-06-04 10:41:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.