Bug 1662274 - APB service name was displayed out of box in web console while using Galaxy server
Summary: APB service name was displayed out of box in web console while using Galaxy s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Jeff Phillips
QA Contact: Zhang Cheng
URL:
Whiteboard:
Depends On: 1668534
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-27 09:25 UTC by Zhang Cheng
Modified: 2019-06-04 10:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Operstors with very long names without any breaks(spaces) Consequence: The operator name would display the name continuing outside of the tile used to display the operator info. Fix: Allow the operator name text to wrap on non-breaks Result: Long names wrap rather than continuing outside of the tile.
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
Galaxy_apb_display (149.15 KB, image/png)
2018-12-27 09:25 UTC, Zhang Cheng
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:36 UTC

Description Zhang Cheng 2018-12-27 09:25:55 UTC
Created attachment 1517020 [details]
Galaxy_apb_display

Description of problem: 
APB service name was displayed out of box in web console while using Galaxy server. PrintScreen refer to attachment.


Version-Release number of selected component (if applicable):
oc v4.0.0-alpha.0+23c8cff-810
asbd 1.3.20
docker.io/automationbroker/automation-broker-operator:latest
docker.io/ansibleplaybookbundle/origin-ansible-service-broker:canary


How reproducible:
Always


Steps to Reproduce:
1. Config apb registry to galaxy and redeploy asb pod.
        type: galaxy
        name: galaxy
        org: ansibleplaybookbundle
        url: https://galaxy.ansible.com 
        runner: registry.access.stage.redhat.com/openshift3/apb-base:v3.11
        white_list: [.*]

2. Check apb items in web console


Actual results: 
2. APB service name was displayed out of box in web console


Expected results: 
2. APB service name should be displayed friendly.


addition info: 
PrintScreen refer to attachment.

Comment 1 Zhang Cheng 2019-01-08 01:55:56 UTC
Changing QA contact to me.

Comment 2 Jeff Phillips 2019-01-08 17:51:45 UTC
PR: https://github.com/openshift/console/pull/1025

Comment 3 Zhang Cheng 2019-02-27 06:59:49 UTC
Changing status to Verified.

Tested with latest build, result is passed.

Payload: 4.0.0-0.nightly-2019-02-26-125216

Comment 6 errata-xmlrpc 2019-06-04 10:41:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.