Bug 1662279 - bregex, bwild: -l option documented but not working
Summary: bregex, bwild: -l option documented but not working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bacula
Version: 29
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Simone Caronni
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-27 09:59 UTC by Wolfgang Denk
Modified: 2019-05-20 08:28 UTC (History)
5 users (show)

Fixed In Version: bacula-9.4.2-1.fc28 bacula-9.4.2-1.fc30 bacula-9.4.2-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-19 05:47:59 UTC


Attachments (Terms of Use)

Description Wolfgang Denk 2018-12-27 09:59:05 UTC
Description of problem:

Both the man pages and the help messages f the bacula tools "bregex" nd "bwild" document a "-l" option, but this is not working.

Version-Release number of selected component (if applicable):

bacula-director-9.2.1-1.fc29.x86_64

How reproducible:

always

Steps to Reproduce:
1. Try to use the "-l" option:

Actual results:

# bregex -l -f /tmp/foo
bregex: invalid option -- 'l'

Usage: bregex [-d debug_level] -f <data-file>
       -f          specify file of data to be matched
       -l          suppress line numbers
       -n          print lines that do not match
       -d <nn>     set debug level to <nn>
       -dt         print timestamp in debug output
       -?          print this message.

# bwild -l -f /tmp/foo
bwild: invalid option -- 'l'

Usage: bwild [-d debug_level] -f <data-file>
       -f          specify file of data to be matched
       -i          use case insenitive match
       -l          suppress line numbers
       -n          print lines that do not match
       -?          print this message.


Expected results:

No error

Additional info:

Comment 1 Fedora Update System 2019-04-29 08:08:41 UTC
bacula-9.4.2-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b4e7243937

Comment 2 Fedora Update System 2019-04-29 08:08:45 UTC
bacula-9.4.2-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-c2ccf00b92

Comment 3 Fedora Update System 2019-04-29 08:08:49 UTC
bacula-9.4.2-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-03688b4f37

Comment 4 Fedora Update System 2019-04-30 02:48:59 UTC
bacula-9.4.2-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-c2ccf00b92

Comment 5 Fedora Update System 2019-04-30 03:40:08 UTC
bacula-9.4.2-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-03688b4f37

Comment 6 Fedora Update System 2019-04-30 15:01:15 UTC
bacula-9.4.2-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b4e7243937

Comment 7 Fedora Update System 2019-05-19 05:47:59 UTC
bacula-9.4.2-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2019-05-19 06:13:34 UTC
bacula-9.4.2-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2019-05-19 10:27:01 UTC
bacula-9.4.2-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Wolfgang Denk 2019-05-20 08:28:16 UTC
Tested with bacula-director-9.4.2-1.fc30.x86_64

Works for me.  Thanks a lot!


Note You need to log in before you can comment on or make changes to this bug.