Bug 1662292 - [Azure][DPDK] The new kind of pmd NETVSC can't rerun the 2nd time [NEEDINFO]
Summary: [Azure][DPDK] The new kind of pmd NETVSC can't rerun the 2nd time
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dpdk
Version: 7.6
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Maxime Coquelin
QA Contact: Yuhui Jiang
URL:
Whiteboard:
Depends On: 1562041
Blocks: 1502856 1676534
TreeView+ depends on / blocked
 
Reported: 2018-12-27 11:13 UTC by Yuhui Jiang
Modified: 2020-01-16 07:13 UTC (History)
17 users (show)

Fixed In Version: dpdk-18.11-3.el7_6
Doc Type: Bug Fix
Doc Text:
When using multiple queues, there was a race with the kernel in setting up the second channel. This regression is due to a kernel change which does not allow accessing sysfs files for Hyper-V channels that are not opened. The fix consists in moving the logic to detect not ready sub channels earlier in the existing loop.
Clone Of:
: 1676534 (view as bug list)
Environment:
Last Closed: 2019-03-12 11:40:10 UTC
Target Upstream Version:
tredaelli: needinfo? (atragler)


Attachments (Terms of Use)
NETVSC pmd log (6.78 KB, text/plain)
2018-12-27 11:15 UTC, Yuhui Jiang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0484 None None None 2019-03-12 11:40:13 UTC

Comment 2 Yuhui Jiang 2018-12-27 11:15:34 UTC
Created attachment 1517039 [details]
NETVSC pmd log

Comment 3 Mohammed Gamal 2019-01-02 06:36:02 UTC
This should've already been fixed in upstream DPDK. The following commits fix it:
https://git.dpdk.org/dpdk/commit/drivers/bus/vmbus?id=4970103e89f4f828669acf3b465e984fdc891e1e
https://git.dpdk.org/dpdk/commit/drivers/bus/vmbus?id=07938364f249d06c658b71911ee32679eeb453e3
https://git.dpdk.org/dpdk/commit/drivers/net/netvsc?id=825ab257b5ce8235ab0cdc260e5b7b757e102875
https://git.dpdk.org/dpdk/commit/drivers/net/netvsc?id=afbc22bf51ab98b9b61b11eb6d38278a9d577111

I think this should be set to CLOSED UPSTREAM. But the question is whether we package the current upstream or backport these patches to our DPDK 18.11 package.

Amnon, any idea what should we do here?

Comment 14 Yuhui Jiang 2019-03-12 08:55:59 UTC
NETVSC pmd need uio_hv_generic(bz#1562041) moduel enabled in RHEL7. According to bz#1562041, after updating kernel version to kernel-3.10.0-993.el7, dpdk-18.11-3.el7_6 works fine in RHEL with NETVSC pmd.
This bug has fixed.

Comment 15 errata-xmlrpc 2019-03-12 11:40:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0484


Note You need to log in before you can comment on or make changes to this bug.