Bug 166231 - input preedit string gets replicated in Evolution Cal (devel)
input preedit string gets replicated in Evolution Cal (devel)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
: Reopened
: 157391 (view as bug list)
Depends On: 131227
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-08-17 23:38 EDT by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-31 10:56:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 264485 None None None Never

  None (edit)
Description Dave Malcolm 2005-08-17 23:38:06 EDT
+++ This bug was initially created as a clone of Bug #131227 +++

Description of problem:
In CJK locale, input characters gets replicated when they are not
comitted.

Version-Release number of selected component (if applicable):
- evolution-data-server-0.0.97-2
- evolution-1.5.92.2-2
- im-sdl-12.0.1-1

How reproducible:
Always

Steps to Reproduce:
1.Select any CJK locale at gdm and log in (in this example, we use Japan)
2.Start Evolution -> Select Cal
3.Ctrl+SPACE to activate the Language Engine
4.Single click any of the time widget and enter 'aka' 
5.Repeat Step 4, you should see the charcters replicating 
  
Actual results:
Please refer to screen shot

Expected results:
Characers does not get replicated.

Additional info:
Tested in GNOME environment
Comment 1 Dave Malcolm 2005-08-17 23:39:15 EDT
What's the status of this in rawhide?
Comment 2 Akira TAGOH 2005-08-18 03:24:12 EDT
Well, I apologize I totally misunderstood about this problem. so this problem
still appears. the real problem is that the preedit buffer isn't reset when the
focus is changed by clicking another cell during preediting. I mean
gtk_im_context_reset has to be called at the focus in/out events.
So correctly this isn't "input preedit string gets replicated" because the
preedit characters isn't committed at the editing cell when another cell is
clicked. but it just appears again at the another cell so that GtkIMContext
doesn't get any the end of preediting notification or so by neither pressing
'enter' nor gtk_im_context_reset().
Comment 3 Christopher Aillon 2006-01-27 15:24:34 EST
there appears to be a fix in http://bugzilla.gnome.org/show_bug.cgi?id=264485
that is stagnating.
Comment 4 Akira TAGOH 2006-02-21 00:31:03 EST
This behavior disappears to me in the latest evolution now. so perhaps we could
close this now?
Comment 5 Akira TAGOH 2006-02-21 06:54:57 EST
Err, this bug is still there. why I couldn't see this at that time is, I've
enabled the global IC mode on scim. but even it introduces another bug on evo.
so the handling of IM on calendar view is totally broken.
Comment 7 Mayank Jain 2006-05-16 06:20:10 EDT
This bug is duplicate of #131227, marking as duplicate.
Comment 8 Mayank Jain 2006-05-16 06:21:48 EDT

*** This bug has been marked as a duplicate of 131227 ***
Comment 11 Mayank Jain 2006-06-21 04:24:39 EDT
Fixed in upstream code... adding the external
bugzilla ref - http://bugzilla.gnome.org/show_bug.cgi?id=264485
Comment 13 Mayank Jain 2006-07-06 05:06:58 EDT
Hi Matt,

The Patch in http://bugzilla.gnome.org/attachment.cgi?id=65213&action=view seems
to be missing from the latest builds. Can you please apply it to the latest code
base?

If you need any more info, please let me know.

PS: this is same bug as bug #157391 and bug #131227 & hopefully the same patch
should do.

Thanks,
Mayank

Comment 14 Matthew Barnes 2006-07-06 12:58:51 EDT
Done - evolution-2.7.3-8

Only two of the three hunks in the patch applied.  The third (plugs a memory
leak) is already fixed upstream.

Changing component from evolution-data-server to evolution.
Comment 15 A S Alam 2006-08-31 10:56:40 EDT
for ja_JP is working fine, no replication for strings
Comment 16 A S Alam 2006-08-31 10:57:51 EDT
*** Bug 157391 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.