Bug 1662310 - tigervnc-server fails to start
Summary: tigervnc-server fails to start
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: tigervnc
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Grulich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-27 15:39 UTC by Colin Henry
Modified: 2020-01-15 14:56 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-15 14:56:00 UTC


Attachments (Terms of Use)
journalctl -xe output (12.26 KB, text/plain)
2018-12-27 15:39 UTC, Colin Henry
no flags Details

Description Colin Henry 2018-12-27 15:39:05 UTC
Created attachment 1517076 [details]
journalctl -xe output

Description of problem:
Attempting to run tigervnc-server fails with a timeout error.

Version-Release number of selected component (if applicable):
Fedora 29 and tigervnc-server-1.9.0-3.fc29.x86_64

How reproducible:
Always fails if you follow the F29 documentation for configuring, docs are out of date, but use the instructions at the top of the config file.

Steps to Reproduce:
1. Install a fresh F29 host (I'm using VMware Workstation)
2. Install tigervnc-server
3. Use the docs at https://docs.fedoraproject.org/en-US/fedora/f29/system-administrators-guide/infrastructure-services/TigerVNC/ to configure VNC. They are out of date and don't reflect the contents of the current confiuration file. Change all instances if USER to the local user
4. Run systemctl start vncserver@:1.service

Actual results:
Error message and VNC fails to start, error message is:
Job for vncserver@:1.service failed because a timeout was exceeded.

Expected results:
VNC to start

Additional info:
Following the instructions at https://www.server-world.info/en/note?os=Fedora_29&p=desktop&f=6 gets further, but I still end up with a just black screen.

Comment 1 Ben Cotton 2019-08-13 16:54:47 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 2 Ben Cotton 2019-08-13 19:38:53 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 3 Jan Grulich 2020-01-15 14:56:00 UTC
I believe this will now work if you follow the comments in systemd service files.


Note You need to log in before you can comment on or make changes to this bug.