Bug 1662312 - openshift-ansible-3.11.51 prevents gluster-block from creating devices
Summary: openshift-ansible-3.11.51 prevents gluster-block from creating devices
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.11.z
Assignee: Scott Dodson
QA Contact: Rachael
URL:
Whiteboard:
Depends On:
Blocks: 1653571 1660280
TreeView+ depends on / blocked
 
Reported: 2018-12-27 15:49 UTC by Niels de Vos
Modified: 2019-04-11 05:38 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
An error in glusterfs pod mountpoints prevented use of gluster-block. Those mount points have been updated to resolve the problem.
Clone Of:
Environment:
Last Closed: 2019-04-11 05:38:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift openshift-ansible pull 10934 None None None 2019-01-02 10:51:44 UTC
Red Hat Knowledge Base (Solution) 3785221 None None None 2019-01-08 11:04:50 UTC
Red Hat Product Errata RHBA-2019:0636 None None None 2019-04-11 05:38:38 UTC

Description Niels de Vos 2018-12-27 15:49:07 UTC
Description of problem:

Once openshift-ansible deploys (installs or upgrades) glusterfs-server, the gluster-block provisioner does not work anymore. 

Details of the requirements that gluster-block/tcmu-runner has can be found in bug 1653571#c8.

Version-Release number of the following components:
openshift-ansible-3.11.51-2

How reproducible:
100%

Steps to Reproduce:
1. deploy with glusterfs storage
2. allocate a PVC through the gluster-block provisioner

Additional info:
Upstream change https://github.com/gluster/gluster-kubernetes/pull/545 will need to be ported to openshift-ansible (release-3.11) once reviewed+merged. This change modifies the /dev volume-mounts again, and depends on an enhancement in the glusterfs-server container to be functional.

Comment 1 Niels de Vos 2019-01-02 10:51:44 UTC
https://github.com/openshift/openshift-ansible/pull/10934 is the PR for openshift-ansible/release-3.11.

Comment 2 Scott Dodson 2019-01-02 14:24:30 UTC
Niels,

How comprehensive of a test matrix do we have around this stuff? Can we work through all the supported configurations to make sure that we've got all of them covered?

Comment 3 Niels de Vos 2019-01-08 10:27:11 UTC
(In reply to Scott Dodson from comment #2)
> Niels,
> 
> How comprehensive of a test matrix do we have around this stuff? Can we work
> through all the supported configurations to make sure that we've got all of
> them covered?

Karthick, can you share the details with Scott?

Comment 5 Scott Dodson 2019-01-08 14:57:25 UTC
In openshift-ansible-3.11.67-1

Comment 20 RamaKasturi 2019-03-11 18:22:18 UTC
Rachael,

   Can you please look at the bug and do the needful ?

Thanks
kasturi

Comment 24 errata-xmlrpc 2019-04-11 05:38:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0636


Note You need to log in before you can comment on or make changes to this bug.