Bug 1662324 - PostBooks can not be installed
Summary: PostBooks can not be installed
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: postbooks
Version: 30
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Daniel Pocock
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-27 17:07 UTC by Pat Barron
Modified: 2019-10-31 19:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Pat Barron 2018-12-27 17:07:57 UTC
Description of problem:

PostBooks can not be installed

Version-Release number of selected component (if applicable):

4.10.1-19.fc28.x86_64

How reproducible:

Reproducible consistently, 100% of the time

Steps to Reproduce:

1. Attempt to install PostBooks using "dnf install postbooks"


Actual results:

Installation fails with the error:

Error: 
 Problem: conflicting requests
  - nothing provides qt5-qtbase(x86-64) = 5.10.1 needed by postbooks-4.10.1-19.fc28.x86_64
  - nothing provides libQt5DesignerComponents.so.5(Qt_5.10.1_PRIVATE_API)(64bit) needed by postbooks-4.10.1-19.fc28.x86_64


Expected results:

PostBooks successfully installed.


Additional info:

Comment 1 Pat Barron 2018-12-27 17:10:18 UTC
I notice that the repo contains this package for "fc28" - should this even be in the Fedora 29 repo?

Comment 2 Pat Barron 2018-12-27 17:25:02 UTC
One other note - I did try "dnf clean all" followed by "dnf makecache" hoping that my cached repo information was just stale, but the result on attempting to install the package remains exactly the same.

Comment 3 Dale Snell 2019-09-13 06:51:04 UTC
I have the same problem.  Doing some investigating, I found that I had qt5-qtbase installed on my system (Fedora 29).  Since the qt5-qttools-libs-designercomponents package was not in my system, I installed it.  Then I tried again to install postbooks.  Still no go.  I note that qt packages are version 5.11.3, while postbooks requires version 5.10.1.  Either postbooks won't work with newer versions of the Qt software (which seems unlikely), or the rpm is just plain broken.  As Pat pointed out above, the postbooks package is built for Fedora 28, not 29.

Comment 4 Ben Cotton 2019-10-31 18:50:39 UTC
This message is a reminder that Fedora 29 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 29 on 2019-11-26.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '29'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 29 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 5 Pat Barron 2019-10-31 19:58:05 UTC
Same problem exists on Fedora 30.


Note You need to log in before you can comment on or make changes to this bug.