Bug 1662335 - sealert throws dbus.proxies:Introspect error
Summary: sealert throws dbus.proxies:Introspect error
Keywords:
Status: CLOSED DUPLICATE of bug 1641456
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: 29
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Lautrbach
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-27 19:30 UTC by ng0177
Modified: 2019-01-02 11:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-02 11:16:22 UTC


Attachments (Terms of Use)

Description ng0177 2018-12-27 19:30:08 UTC
$ uname -r
4.19.10-300.fc29.x86_64

$ sealert
/usr/bin/sealert:32: DeprecationWarning: Importing dbus.glib to use the GLib main loop with dbus-python is deprecated.
Instead, use this sequence:

    from dbus.mainloop.glib import DBusGMainLoop

    DBusGMainLoop(set_as_default=True)

  import dbus.glib
ERROR:dbus.proxies:Introspect error on :1.91:/org/fedoraproject/Setroubleshootd: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying
could not attach to desktop process

This error comes up on a fresh F29 installtion on an AM4 AMD board. Any clues as to further locate the error? Thanks!

Comment 1 Petr Lautrbach 2018-12-28 20:45:51 UTC
I believe this is a dbus bug, see https://bugzilla.redhat.com/show_bug.cgi?id=1641456

The following command should fix it for you:

# dnf reinstall dbus-common dbus-daemon

Comment 2 ng0177 2018-12-29 10:47:01 UTC
confirmed and fixed. Thanks!

Comment 3 Petr Lautrbach 2019-01-02 11:16:22 UTC

*** This bug has been marked as a duplicate of bug 1641456 ***


Note You need to log in before you can comment on or make changes to this bug.