Bug 1662336 - unable to scroll up in udisksctl dump command if bottom of output is reached
Summary: unable to scroll up in udisksctl dump command if bottom of output is reached
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: udisks2
Version: 8.0
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: 8.0
Assignee: Tomáš Bžatek
QA Contact: guazhang@redhat.com
URL:
Whiteboard:
Depends On: 1682538 1685210
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-27 19:33 UTC by John Pittman
Modified: 2019-11-05 21:18 UTC (History)
4 users (show)

Fixed In Version: udisks2-2.8.3-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 21:18:34 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3459 None None None 2019-11-05 21:18:41 UTC

Description John Pittman 2018-12-27 19:33:48 UTC
Description of problem:

When using 'udisksadm dump', if the user reaches the bottom of the output, they can not scroll back up.  The only way to move forward is ctrl-c or kill the pid.

Version-Release number of selected component (if applicable):

libudisks2-2.8.0-2.el8.x86_64
udisks2-2.8.0-2.el8.x86_64

Steps to Reproduce:
- Run command 'udisksctl dump'
- Page down to the bottom of the output
- Attempt to page back up


Actual results:

The user can not page back up once the bottom of the output is reached; only ctrl-c out.  If the bottom is not reached, the user can scroll back up.

Expected results:

User should be able to scroll as needed.  It seems results would be better if output scrolling functioned like 'less' command.

Comment 1 Tomáš Bžatek 2018-12-31 21:18:52 UTC
Confirming, reproducible on different systems.

Comment 2 xhe@redhat.com 2019-01-04 06:11:21 UTC
I can reproduce it on udisks2-2.8.0-2.el8, let me add ack+

Comment 3 xhe@redhat.com 2019-01-04 06:15:47 UTC
Hi Tomas,

Do you know there are any automation ways to check this issue? I don't know how to check the scroll of screen with code.

Comment 4 Tomáš Bžatek 2019-01-04 13:59:06 UTC
(In reply to xhe@redhat.com from comment #3)
> Hi Tomas,
> 
> Do you know there are any automation ways to check this issue? I don't know
> how to check the scroll of screen with code.

Hmm, you may set the PAGER env. var. to something else than `less` and observe that udisksctl left the stdout open. I'm not aware of any nice and easy solution right away. Perhaps a simple python script acting like a page could do the trick (just an idea).

Comment 6 guazhang@redhat.com 2019-06-18 10:07:19 UTC
Hello

I have installed udisks2-2.8.3-2.el8.x86_64 to my test server, and udisksctl dump commands,  page down,page up work well when page down to bottom of the output, so move to verified 

thanks
Guazhang

Comment 8 errata-xmlrpc 2019-11-05 21:18:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3459


Note You need to log in before you can comment on or make changes to this bug.