Bug 166239 - Netfs (nfs) doesnt mount at boot time
Netfs (nfs) doesnt mount at boot time
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: nfs-utils (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-18 04:02 EDT by Patrick Steiner
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:55:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Steiner 2005-08-18 04:02:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
We have got 2 RH ES 3 servers. Both have the same problem. Netfs wont start at boot time. if i start the service manual all works fine.

here is the error message i get:

Aug 17 21:22:30 ADMOGO mount: mount: RPC: Remote system error - No route to host

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.reboot server
2.netfs service doesnt start at boot time
3.starting netfs service manual all works fine
  

Actual Results:  i dont have any network shares

Expected Results:  i have got network shares

Additional info:
Comment 1 Steve Dickson 2005-08-18 06:20:47 EDT
It appears your network interface is  either not coming up during boot
or your routine table is not set when NFS tries the mount. Is there anything
in /var/log/message that is complaining about something?
Comment 2 Patrick Steiner 2005-08-18 08:45:01 EDT
i cant find anyting in the log file.

the only thing is that i cant ping the nfs-server at boot time (added an ping -c
nfs-server into the netfs boot script).

Comment 3 Steve Dickson 2005-08-18 09:37:57 EDT
Would it be possible to get an network trace of this occurrence?
Probably the easies way would be from the server side.

If the server is Linux use:
'tethereal -w /tmp/data.pcap host nfs-client ; bzip2 /tmp/data.pcap'

if the server is another OS, see if the tcpdump command exists. If
so do a 'tcpdump -s 0 -w /tmp/data.pcap ; gzip /tmp/data.pcap'
Comment 5 Rainer Traut 2007-10-18 09:09:39 EDT
I am seeing this, too on EL4 U5:

/var/log/messages:
Oct 18 14:33:53 test1-ent network: Netzwerkparameter einstellen:  succeeded
Oct 18 14:33:53 test1-ent network: Loopback Schnittstelle hochfahren:  succeeded
Oct 18 14:33:58 test1-ent network: Schnittstelle eth0 hochfahren:  succeeded      
Oct 18 14:34:18 test1-ent mount: mount: Konnte die Adresse von
report01.domain.de nicht herausfinden
Oct 18 14:34:18 test1-ent netfs: NFS-Dateisysteme einhängen:  failed
Oct 18 14:34:19 test1-ent netfs: Andere Dateisysteme einhängen:  succeeded  

A tcpdump on the server seems useless because the request is not send out as the
message states.

After boot the mount succeeds:

[root@test1-ent ~]# mount -av
mount: LABEL=/boot ist bereits auf /boot eingehängt
mount: none ist bereits auf /dev/pts eingehängt
mount: none ist bereits auf /dev/shm eingehängt
mount: none ist bereits auf /proc eingehängt
mount: /dev/VG00/LVsrv ist bereits auf /srv eingehängt
mount: none ist bereits auf /sys eingehängt
mount: /dev/VG00/LVtmp ist bereits auf /tmp eingehängt
mount: /dev/VG00/LVvar ist bereits auf /var eingehängt
mount: trying 172.27.16.17 prog 100003 vers 3 prot tcp port 2049
mount: trying 172.27.16.17 prog 100005 vers 3 prot udp port 1009
report01.domain.de:/home/report/reportjobs on
/srv/notesdata/domino/html/reportjobs type nfs
(rw,soft,intr,rsize=8192,wsize=8192,nfsvers=3,addr=172.27.16.17)
[root@test1-ent ~]#
Comment 6 RHEL Product and Program Management 2007-10-19 14:55:58 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.