Bug 1662474 - Cannot install all Perl modules correctly.
Summary: Cannot install all Perl modules correctly.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jitka Plesnikova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-28 19:46 UTC by Wayne Hammond
Modified: 2019-01-02 13:01 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-02 12:49:12 UTC
Type: Bug


Attachments (Terms of Use)

Description Wayne Hammond 2018-12-28 19:46:40 UTC
Description of problem:Cannot run existing perl scripts, errors  attempting to install all Perl modules.


Version-Release number of selected component (if applicable): Fedora 29


How reproducible: Always


Steps to Reproduce:
1.Run sudo dnf install perl*
2.Errors generated
3.

Actual results:Scripts fail


Expected results:Scripts run


Additional info:
Error: 
 Problem 1: conflicting requests
  - nothing provides perl(JavaScript::Packer1) needed by perl-JavaScript-Beautifier-0.25-3.fc29.noarch
 Problem 2: package perl-Code-TidyAll-Plugin-JSBeautifier-0.25-3.fc29.noarch requires /usr/bin/js_beautify.pl, but none of the providers can be installed
  - conflicting requests
  - nothing provides perl(JavaScript::Packer1) needed by perl-JavaScript-Beautifier-0.25-3.fc29.noarch
 Problem 3: package perl-libnodeupdown-1.14-21.fc27.x86_64 requires libperl.so.5.26()(64bit), but none of the providers can be installed
  - package perl-libnodeupdown-1.14-21.fc27.x86_64 requires perl(:MODULE_COMPAT_5.26.0), but none of the providers can be installed
  - conflicting requests
  - package perl-libs-4:5.26.2-410.module_1681+b405d8e2.x86_64 is excluded
  - package perl-libs-4:5.26.2-413.module_2073+eebc5b71.x86_64 is excluded
  - package perl-libs-4:5.26.3-415.module_2543+eed510a0.x86_64 is excluded
 Problem 4: package perl-Mail-SPF_XS-0.01-17.20150405gitd57d79fd.fc28.x86_64 requires libperl.so.5.26()(64bit), but none of the providers can be installed
  - package perl-Mail-SPF_XS-0.01-17.20150405gitd57d79fd.fc28.x86_64 requires perl(:MODULE_COMPAT_5.26.1), but none of the providers can be installed
  - conflicting requests
  - package perl-libs-4:5.26.2-410.module_1681+b405d8e2.x86_64 is excluded
  - package perl-libs-4:5.26.2-413.module_2073+eebc5b71.x86_64 is excluded
  - package perl-libs-4:5.26.3-415.module_2543+eed510a0.x86_64 is excluded

Comment 1 Petr Pisar 2019-01-02 12:49:12 UTC
Please report your issues for every package separately. The problem is not in perl. It's in the respective packages.

Also be sure to report correct Fedora version. E.g. you log shows perl-JavaScript-Beautifier-0.25-3.fc29.noarch, a Fedora 29 package. But you opened this bug report against Fedora 28.

Comment 2 Petr Pisar 2019-01-02 13:01:43 UTC
Example for perl-JavaScript-Beautifier: bug #1662932.


Note You need to log in before you can comment on or make changes to this bug.