Bug 1662509 - [abrt] nf_conncount_destroy: general protection fault in nf_conncount_destroy [nf_conncount]
Summary: [abrt] nf_conncount_destroy: general protection fault in nf_conncount_destroy...
Keywords:
Status: CLOSED DUPLICATE of bug 1659706
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:37e86af996a6c9f3e927ba299a7...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-29 04:50 UTC by Joseph D. Wagner
Modified: 2019-01-17 20:27 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-17 20:27:59 UTC


Attachments (Terms of Use)
File: dmesg (76.40 KB, text/plain)
2018-12-29 04:50 UTC, Joseph D. Wagner
no flags Details

Description Joseph D. Wagner 2018-12-29 04:50:14 UTC
Description of problem:
Disabling this firewall rule appears to stop the problem.
#-A INPUT -m conntrack --ctstate NEW -m connlimit --connlimit-above 2 -j DROP

Additional info:
reporter:       libreport-2.9.7
general protection fault: 0000 [#1] SMP PTI
CPU: 0 PID: 2390 Comm: iptables Kdump: loaded Not tainted 4.19.10-300.fc29.x86_64 #1
Hardware name: ASUS All Series/Q87M-E, BIOS 3602 03/26/2018
RIP: 0010:rb_erase+0x216/0x370
Code: e9 6b fe ff ff 4d 89 48 10 e9 91 fe ff ff c3 48 89 06 48 89 d0 48 8b 52 10 e9 b1 fe ff ff 48 8b 07 48 89 c1 48 83 e1 fc 74 53 <48> 3b 79 10 0f 84 94 00 00 00 4c 89 41 08 4d 85 c0 75 4c a8 01 0f
RSP: 0018:ffffabfb83d43d28 EFLAGS: 00010202
RAX: 0a58c21f032795ee RBX: ffff90a1753c73c0 RCX: 0a58c21f032795ec
RDX: 0000000000000000 RSI: ffff90a1778d02c0 RDI: ffff90a1753c73c0
RBP: ffff90a1757bc3c8 R08: 0000000000000000 R09: ffffffffc0aa03de
R10: ffff90a17e7580c0 R11: 0000000000000001 R12: ffff90a1778d02c0
R13: ffff90a1778d0808 R14: ffff90a1778d0000 R15: ffff90a1753c73e0
FS:  00007fdc5e648740(0000) GS:ffff90a1bda00000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 000055d0cb6d1000 CR3: 00000007b5f2a004 CR4: 00000000001606f0
Call Trace:
 nf_conncount_destroy+0x58/0xc0 [nf_conncount]
 cleanup_match+0x45/0x70
 cleanup_entry+0x3e/0xc0
 __do_replace+0x1ca/0x230
 do_ipt_set_ctl+0x146/0x1a2
 nf_setsockopt+0x44/0x70
 __sys_setsockopt+0x82/0xe0
 __x64_sys_setsockopt+0x20/0x30
 do_syscall_64+0x5b/0x160
 entry_SYSCALL_64_after_hwframe+0x44/0xa9
RIP: 0033:0x7fdc5e751cce
Code: d8 64 89 02 48 c7 c0 ff ff ff ff eb b1 66 2e 0f 1f 84 00 00 00 00 00 0f 1f 44 00 00 f3 0f 1e fa 49 89 ca b8 36 00 00 00 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d 8a 11 0c 00 f7 d8 64 89 01 48
RSP: 002b:00007ffcb568c878 EFLAGS: 00000202 ORIG_RAX: 0000000000000036
RAX: ffffffffffffffda RBX: 000055d0cb6cc268 RCX: 00007fdc5e751cce
RDX: 0000000000000040 RSI: 0000000000000000 RDI: 0000000000000004
RBP: 000055d0cb6d09c0 R08: 0000000000002098 R09: 0000000000000000
R10: 000055d0cb6d09c0 R11: 0000000000000202 R12: 000055d0cb6d0a20
R13: 000055d0cb6cc268 R14: 0000000000002038 R15: 000055d0cb6cc260
Modules linked in: iptable_mangle xt_CHECKSUM iptable_nat ipt_MASQUERADE nf_nat_ipv4 nf_nat tun bridge stp llc devlink ebtable_filter ebtables cls_u32 sch_sfq sch_prio sch_htb xt_connlimit nf_conncount xt_state xt_pkttype xt_conntrack nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 ip6table_filter ip6_tables sunrpc xfs vfat fat libcrc32c intel_rapl mei_wdt x86_pkg_temp_thermal intel_powerclamp coretemp iTCO_wdt iTCO_vendor_support kvm_intel ppdev snd_hda_codec_hdmi kvm snd_hda_codec_realtek snd_hda_codec_generic irqbypass intel_cstate snd_hda_intel intel_uncore intel_rapl_perf snd_hda_codec eeepc_wmi snd_hda_core snd_hwdep asus_wmi snd_seq snd_seq_device sparse_keymap rfkill wmi_bmof i2c_i801 snd_pcm ses enclosure scsi_transport_sas mei_me mei joydev usblp lpc_ich snd_timer snd soundcore parport_pc
 parport tpm_infineon pcc_cpufreq dm_crypt nouveau mxm_wmi i2c_algo_bit drm_kms_helper crct10dif_pclmul ttm crc32_pclmul crc32c_intel uas drm ghash_clmulni_intel e1000e usb_storage wmi video

Comment 1 Joseph D. Wagner 2018-12-29 04:50:18 UTC
Created attachment 1517310 [details]
File: dmesg

Comment 2 Joseph D. Wagner 2018-12-29 12:15:58 UTC
I changed kdump.conf to use my unencrypted boot partition, and I was able to reproduce the crash.

However, I got was this one file:
/boot/crash/127.0.0.1-2018-12-29-04\:03\:15/vmcore-dmesg-incomplete.txt

Comment 3 Jeremy Cline 2019-01-17 20:27:59 UTC
Thanks for the report, Joseph. I believe this is a duplicate (and should be fixed in the current Rawhide kernel, can you confirm that?).

*** This bug has been marked as a duplicate of bug 1659706 ***


Note You need to log in before you can comment on or make changes to this bug.