Bug 1662512 - Calc freezes at opening Excel file or saving an ODS file converted from Excel.
Summary: Calc freezes at opening Excel file or saving an ODS file converted from Excel.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 29
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-29 06:09 UTC by Fiable.biz
Modified: 2019-01-12 01:57 UTC (History)
4 users (show)

Fixed In Version: libreoffice-6.1.4.2-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-12 01:57:38 UTC


Attachments (Terms of Use)
File which cannot be opened at all (19.00 KB, application/x-ole-storage)
2018-12-29 06:09 UTC, Fiable.biz
no flags Details


Links
System ID Priority Status Summary Last Updated
Document Foundation 121855 None None None 2019-01-07 10:27:59 UTC
Document Foundation 121981 None None None 2019-01-07 10:20:34 UTC

Description Fiable.biz 2018-12-29 06:09:31 UTC
Created attachment 1517311 [details]
File which cannot be opened at all

Description of problem:
The problem is described there:
https://bugs.documentfoundation.org/show_bug.cgi?id=121981
and seems no to be a LibreOffice bug. May it be a packaging bug?
At opening an xls file, or at saving two other files converted from xlsx files into ods files and to which a sheet has been added or from which a sheet has been deleted, LibreOffice freezes.

Version-Release number of selected component (if applicable):
6.1.2.1

How reproducible:
Always with those 3 files, even in safe mode.

Steps to Reproduce:
1. Double-click on the file from the file manager.

Actual results:
LibreOffice freezes.

Expected results:
LibreOffice open the file.

Additional info:
If I remember well (which is not sure), LibreOffice is only in English by default on Fedora workstation, even if French is chosen as one of the system languages, so I probably installed the French package later by hand by launching "dnf install libreoffice-langpack-fr".

Comment 1 Caolan McNamara 2019-01-07 10:26:43 UTC
This is an accessibility thing, which is why not everyone sees it.

Comment 2 Fedora Update System 2019-01-08 08:56:55 UTC
libreoffice-6.1.4.2-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-626f5cf902

Comment 3 Fedora Update System 2019-01-10 22:14:39 UTC
libreoffice-6.1.4.2-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-626f5cf902

Comment 4 Fedora Update System 2019-01-12 01:57:38 UTC
libreoffice-6.1.4.2-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.