Bug 1662523 - [RHEL7] Meet a conflict between python3-inotify and python-inotify when Leapp upgrades RHEL7.6 to RHEL8.0
Summary: [RHEL7] Meet a conflict between python3-inotify and python-inotify when Leapp...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: leapp-repository
Version: 7.6
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Vojtech Sokol
QA Contact: Alois Mahdal
URL:
Whiteboard:
Depends On:
Blocks: 1622152
TreeView+ depends on / blocked
 
Reported: 2018-12-29 09:12 UTC by boyang
Modified: 2019-01-07 01:28 UTC (History)
5 users (show)

Fixed In Version: leapp-repository-0.4.0-4.el7_6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-03 14:49:08 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description boyang 2018-12-29 09:12:18 UTC
Description of problem: 
From the BZ1622152 [ESXi][RHEL8]In-place upgrade from RHEL 7.6 to RHEL 8.0 on VMware, use leapp to upgrade RHEL7.6 to RHEL8.0, but met the conflict between python3-inotify and python-inotify


Version-Release number of selected component (if applicable): 
Host: ESXi6.7
Guest: RHEL7.6 - kernel-3.10.0-957.el7.x86_64
Storage: SCSI
Leapp: 0.4.0


How reproducible: 
100% 


Steps to Reproduce: 
1. Install RHEL7.6 as the Guest in a VM based on above ENV
2. Config subscription-manager account, repo in the Guest.
3. "leapp upgrade --debug"


Actual results: 
After step 3, leapp upgrading fails as  the conflict between python3-inotify and python-inotify


Expected results: 
After step 3, the conflict should be resolved by leapp during upgrading


Additional:
Get a workaround, put the python-inotify to /etc/leapp/transaction/to_remove, will resolve the conflict, and complete the upgrading

Comment 2 Petr Stodulka 2019-01-03 14:49:08 UTC
The problem is already fixed in the latest build.


Note You need to log in before you can comment on or make changes to this bug.