Bug 1662590 - [CEE 8.0] Failed to setup system with Boot EFI when encrypting root with luks
Summary: [CEE 8.0] Failed to setup system with Boot EFI when encrypting root with luks
Keywords:
Status: CLOSED DUPLICATE of bug 1628519
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: anaconda
Version: 8.0
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
: 1662584 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-30 13:49 UTC by Shivam Gupta
Modified: 2018-12-30 14:10 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-30 14:10:09 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
logs from installer (202.10 KB, application/gzip)
2018-12-30 13:49 UTC, Shivam Gupta
no flags Details

Description Shivam Gupta 2018-12-30 13:49:46 UTC
Created attachment 1517467 [details]
logs from installer

Description of problem:
Failed to setup system with Boot EFI when encrypting root with luks 


Version-Release number of selected component (if applicable):

cat kernel 
4.18.0-40.el8.x86_64

# cat lorax-packages.log | grep -e kernel -e anaconda
anaconda-core-29.19.0.25-1.el8.x86_64
anaconda-install-env-deps-29.19.0.25-1.el8.x86_64
anaconda-tui-29.19.0.25-1.el8.x86_64
anaconda-widgets-29.19.0.25-1.el8.x86_64
anaconda-gui-29.19.0.25-1.el8.x86_64
kdump-anaconda-addon-003-2.20181107git443d7ed.el8.noarch
oscap-anaconda-addon-1.0-3.el8.noarch
kernel-core-4.18.0-40.el8.x86_64
anaconda-dracut-29.19.0.25-1.el8.x86_64
libreport-rhel-anaconda-bugzilla-2.9.5-6.el8.x86_64
kernel-4.18.0-40.el8.x86_64
kernel-modules-4.18.0-40.el8.x86_64
libreport-anaconda-2.9.5-6.el8.x86_64
anaconda-user-help-8.0.6-1.el8.noarch
anaconda-29.19.0.25-1.el8.x86_64
kernel-modules-extra-4.18.0-40.el8.x86_64

# cat lorax-packages.log | grep -i cryptsetup
cryptsetup-2.0.4-2.el8.x86_64
cryptsetup-libs-2.0.4-2.el8.x86_64


# cat release
Red Hat Enterprise Linux release 8.0 Beta


How reproducible:
* Always readily reproducible 


Steps to Reproduce:
1. Enable EFI on vmware system and try to set up a new system with luks.
2.
3.

Actual results:
pop out an error as "An unknown error has occurred"


Expected results:
The system should get configured with root being encrypted via luks.


Additional info:

Comment 1 Shivam Gupta 2018-12-30 13:50:18 UTC
*** Bug 1662584 has been marked as a duplicate of this bug. ***

Comment 2 Shivam Gupta 2018-12-30 14:10:09 UTC

*** This bug has been marked as a duplicate of bug 1628519 ***


Note You need to log in before you can comment on or make changes to this bug.