Bug 166266 - Route for 169.254.* to lo conflicts with autoip
Route for 169.254.* to lo conflicts with autoip
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: howl (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-18 09:59 EDT by David Anderson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: initscripts-8.11.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-09 11:55:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Anderson 2005-08-18 09:59:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4) KHTML/3.4.2 (like Gecko)

Description of problem:
I connected two Fedora Core 4 systems with a crossover cable (Ethernet). 
 
There doesn't yet seem to be a facility for automating the bringing up of a 
link-local (169.254.x.y) IP address, so I had to go to the terminal and run 
"autoipd" on both boxes. This assigned 169.254. addresses to the Ethernet 
cards. 
 
However by default there seems to be a route in the routing table sending 
169.254. to the 'lo' interface. I don't know why. It prevents connectivity 
until removed (in my case I did '/sbin/ifdown lo'). 
 
What happens: No link-local connectivity possible because of route to lo 
What should happen: Should 'just work' 
 
Also, it seems to me that system-config-network should have checkboxes that 
are accessible if DHCP is chosen, so that we get a 'it just works' situation: 
[ ] Automatically bring interface up/down on cable connection 
[ ] Assign link-local IP address if no DHCP address can be found 
 
And these should do magic with howl... this is of course a separate bug, but I 
don't know if it's already being worked on. If it's not, I'll file a bug - can 
you let me know if you want this? 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
 

Additional info:
Comment 1 Jason Vas Dias 2006-03-09 11:55:50 EST
This is now fixed with the latest version of initscripts in FC-4/updates:

in /etc/sysconfig/network-scripts/ifup-eth:

# Add Zeroconf route.
if [ -z "${NOZEROCONF}" -a "${ISALIAS}" = "no" ]; then
    ip route replace 169.254.0.0/16 dev ${REALDEVICE}
fi

$ ip route
...
169.254.0.0/16 dev eth0  scope link
...


Note You need to log in before you can comment on or make changes to this bug.