Bug 1662661 - [abrt] gnome-software: g_hash_table_lookup_node(): gnome-software killed by SIGABRT
Summary: [abrt] gnome-software: g_hash_table_lookup_node(): gnome-software killed by S...
Keywords:
Status: CLOSED DUPLICATE of bug 1570096
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:3cc4fbbbef8f5b45fb0de196497...
: 1662721 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-31 10:24 UTC by ep
Modified: 2019-01-01 00:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-31 11:02:21 UTC


Attachments (Terms of Use)
File: backtrace (45.25 KB, text/plain)
2018-12-31 10:24 UTC, ep
no flags Details
File: cgroup (195 bytes, text/plain)
2018-12-31 10:24 UTC, ep
no flags Details
File: core_backtrace (24.03 KB, text/plain)
2018-12-31 10:24 UTC, ep
no flags Details
File: cpuinfo (1.34 KB, text/plain)
2018-12-31 10:24 UTC, ep
no flags Details
File: dso_list (16.52 KB, text/plain)
2018-12-31 10:24 UTC, ep
no flags Details
File: environ (4.13 KB, text/plain)
2018-12-31 10:24 UTC, ep
no flags Details
File: limits (1.29 KB, text/plain)
2018-12-31 10:24 UTC, ep
no flags Details
File: maps (102.74 KB, text/plain)
2018-12-31 10:25 UTC, ep
no flags Details
File: mountinfo (4.14 KB, text/plain)
2018-12-31 10:25 UTC, ep
no flags Details
File: open_fds (3.59 KB, text/plain)
2018-12-31 10:25 UTC, ep
no flags Details
File: proc_pid_status (1.31 KB, text/plain)
2018-12-31 10:25 UTC, ep
no flags Details
File: var_log_messages (1.66 KB, text/plain)
2018-12-31 10:25 UTC, ep
no flags Details

Description ep 2018-12-31 10:24:48 UTC
Version-Release number of selected component:
gnome-software-3.30.6-1.fc29

Additional info:
reporter:       libreport-2.9.7
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: g_hash_table_lookup_node
executable:     /usr/bin/gnome-software
journald_cursor: s=e64f930b9c154c3e9f4444c129a2bcb4;i=1d6e1;b=456d119c62ff42fb9ad00428f2c2e007;m=29e5095;t=57e4eb404d378;x=f22cdd35a3b6c0cc
kernel:         4.19.10-300.fc29.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 2 (8 frames)
 #4 g_hash_table_lookup_node at ghash.c:377
 #6 g_hash_table_lookup at ghash.c:1153
 #7 as_app_add_token_internal at ../libappstream-glib/as-app.c:5839
 #8 as_app_add_tokens at ../libappstream-glib/as-app.c:5914
 #9 as_app_create_token_cache_target at ../libappstream-glib/as-app.c:5943
 #10 as_app_create_token_cache at ../libappstream-glib/as-app.c:5999
 #11 as_app_search_matches at ../libappstream-glib/as-app.c:6029
 #13 g_thread_proxy at gthread.c:784

Potential duplicate: bug 1570096

Comment 1 ep 2018-12-31 10:24:52 UTC
Created attachment 1517612 [details]
File: backtrace

Comment 2 ep 2018-12-31 10:24:53 UTC
Created attachment 1517614 [details]
File: cgroup

Comment 3 ep 2018-12-31 10:24:55 UTC
Created attachment 1517617 [details]
File: core_backtrace

Comment 4 ep 2018-12-31 10:24:56 UTC
Created attachment 1517619 [details]
File: cpuinfo

Comment 5 ep 2018-12-31 10:24:57 UTC
Created attachment 1517620 [details]
File: dso_list

Comment 6 ep 2018-12-31 10:24:58 UTC
Created attachment 1517623 [details]
File: environ

Comment 7 ep 2018-12-31 10:24:59 UTC
Created attachment 1517625 [details]
File: limits

Comment 8 ep 2018-12-31 10:25:01 UTC
Created attachment 1517627 [details]
File: maps

Comment 9 ep 2018-12-31 10:25:03 UTC
Created attachment 1517628 [details]
File: mountinfo

Comment 10 ep 2018-12-31 10:25:04 UTC
Created attachment 1517629 [details]
File: open_fds

Comment 11 ep 2018-12-31 10:25:05 UTC
Created attachment 1517630 [details]
File: proc_pid_status

Comment 12 ep 2018-12-31 10:25:06 UTC
Created attachment 1517631 [details]
File: var_log_messages

Comment 13 Kalev Lember 2018-12-31 11:02:21 UTC

*** This bug has been marked as a duplicate of bug 1570096 ***

Comment 14 Tej Patil 2019-01-01 00:28:37 UTC
*** Bug 1662721 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.