Bug 1662669 - Can't log in to engine UI with: JBWEB004038: An exception occurred processing JSP page /WEB-INF/login.jsp at line 41
Summary: Can't log in to engine UI with: JBWEB004038: An exception occurred processin...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: AAA
Version: 4.3.0
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: ovirt-4.2.8
: ---
Assignee: Ravi Nori
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-31 12:28 UTC by Michael Burman
Modified: 2019-01-22 10:23 UTC (History)
6 users (show)

Fixed In Version: ovirt-engine-4.2.8.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-22 10:23:38 UTC
oVirt Team: Infra
rule-engine: ovirt-4.2+
rule-engine: blocker+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 96423 None None None 2019-01-01 16:09:19 UTC
oVirt gerrit 96524 ovirt-engine-4.2 MERGED engine: work around server 500 in login.jsp 2019-01-03 13:12:01 UTC

Description Michael Burman 2018-12-31 12:28:37 UTC
Description of problem:

After updating to latest 4.2.8 u/s 4.2.8.2-0.0.master.20181220151741.git3125fe8.el7
engine is dead with in internal server error and exception in server log -

2018-12-23 09:53:07,557+02 ERROR [io.undertow.request] (default task-5) UT005023: Exception handling request to /ovirt-engine/sso/login.html: org.apache.jasper.JasperExcep
tion: JBWEB004038: An exception occurred processing JSP page /WEB-INF/login.jsp at line 41

41

38:     <div class="obrand_landingBgTop"></div>
39:     <div class="obrand_landingBgBottom"></div>
40:
41:     <a href="${applicationScope['ovirt-ssoContext'].getEngineUrl(pageContext.request)}" class="obrand_loginPageLogoLink">
42:         <span class="obrand_loginPageLogo"></span>
43:     </a>
44:     <div class="ovirt-container">

Version-Release number of selected component (if applicable):
4.2.8.2-0.0.master.20181220151741.git3125fe8.el7

Steps to Reproduce:
1. Try to upgrade to 4.2.8.2-0.0.master.20181220151741.git3125fe8.el7

Actual results:
engine-setup failed and engine is dead

Expected results:
Should work

Comment 1 Yedidyah Bar David 2019-01-01 06:17:21 UTC
Please attach logs (e.g. sosreport). Thanks.

Comment 3 Greg Sheremeta 2019-01-01 16:08:11 UTC
Did the engine-setup command actually throw an error, or did it complete successfully? As far as I understood previously, the engine setup was fine but you just couldn't log in because of this JSP issue (totally unrelated to engine-setup, the JSP is AAA/UX)

Comment 5 Lucie Leistnerova 2019-01-15 10:25:22 UTC
I don't see any problem with login to admin/VM portal with internal user.

verified in ovirt-engine-4.2.8.2-0.1.el7ev.noarch
with ovirt-engine-extension-aaa-jdbc-1.1.7-1.el7ev.noarch

Comment 6 Sandro Bonazzola 2019-01-22 10:23:38 UTC
This bugzilla is included in oVirt 4.2.8 release, published on January 22nd 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.2.8 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.