Bug 1662675 - Wrong dependencies when remove google-noto-emoji-fonts
Summary: Wrong dependencies when remove google-noto-emoji-fonts
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: google-noto-emoji-fonts
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peng Wu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-31 14:07 UTC by lonr
Modified: 2019-01-02 06:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-02 06:32:12 UTC


Attachments (Terms of Use)

Description lonr 2018-12-31 14:07:56 UTC
Description of problem:
dnf trys to remove other packges when I'm trying to remove emoji font

Version-Release number of selected component (if applicable):
20180814-1.fc29

How reproducible:


Steps to Reproduce:
sudo dnf remove google-noto-emoji-color-fonts

Actual results:
Dependencies resolved.
================================================================================
 Package                               Arch   Version           Repository
                                                                           Size
================================================================================
Removing:
 google-noto-emoji-color-fonts         noarch 20180814-1.fc29   @anaconda 7.6 M
Removing dependent packages:
 cheese                                x86_64 2:3.30.0-2.fc29   @anaconda 438 k
 chrome-gnome-shell                    x86_64 10.1-3.fc29       @anaconda  61 k
 eog                                   x86_64 3.28.4-1.fc29     @anaconda  11 M
 evince-nautilus                       x86_64 3.30.2-2.fc29     @updates   23 k
 evolution-ews                         x86_64 3.30.3-1.fc29     @updates  1.3 M
 evolution-help                        noarch 3.30.3-1.fc29     @updates   13 M
 gnome-classic-session                 noarch 3.30.1-1.fc29     @anaconda 200 k
 gnome-clocks                          x86_64 3.30.1-1.fc29     @updates  1.4 M
 gnome-contacts                        x86_64 3.30.2-1.fc29     @updates  1.6 M
 gnome-documents                       x86_64 3.30.0-1.fc29     @anaconda 2.2 M
 gnome-font-viewer                     x86_64 3.30.0-1.fc29     @anaconda 731 k
 gnome-initial-setup                   x86_64 3.30.0-1.fc29     @anaconda 2.6 M
 gnome-photos                          x86_64 3.30.1-1.fc29     @anaconda 4.8 M
 gnome-shell-extension-background-logo noarch 3.24.0-6.fc29     @anaconda  58 k
 gnome-software                        x86_64 3.30.6-1.fc29     @updates  9.1 M
 totem-nautilus                        x86_64 1:3.30.0-1.fc29   @updates   43 k
Removing unused dependencies:
 accountsservice                       x86_64 0.6.54-1.fc29     @anaconda 351 k
 accountsservice-libs                  x86_64 0.6.54-1.fc29     @anaconda 311 k
 adwaita-gtk2-theme                    x86_64 3.28-2.fc29       @anaconda 253 k
 appstream-data                        noarch 29-8.fc29         @updates   17 M
 bolt                                  x86_64 0.6-1.fc29        @updates  439 k
 cheese-libs                           x86_64 2:3.30.0-2.fc29   @anaconda 2.3 M
 dleyna-connector-dbus                 x86_64 0.3.0-3.fc29      @anaconda  48 k
 dleyna-core                           x86_64 0.6.0-3.fc29      @anaconda  68 k
 dleyna-renderer                       x86_64 0.6.0-3.fc29      @anaconda 158 k
 dleyna-server                         x86_64 0.6.0-3.fc29      @anaconda 225 k
 epiphany-runtime                      x86_64 1:3.30.2-1.fc29   @updates  1.9 M
 evince                                x86_64 3.30.2-2.fc29     @updates  9.2 M
 evolution                             x86_64 3.30.3-1.fc29     @updates   15 M
 evolution-ews-langpacks               noarch 3.30.3-1.fc29     @updates  912 k
 evolution-langpacks                   noarch 3.30.3-1.fc29     @updates   35 M
 frei0r-plugins                        x86_64 1.6.1-6.fc29      @anaconda 6.0 M
 fwupd                                 x86_64 1.1.4-1.fc29      @updates  4.6 M
 gavl                                  x86_64 1.4.0-13.fc29     @anaconda 4.3 M
 gdm                                   x86_64 1:3.30.1-2.fc29   @anaconda 2.3 M
 gnome-control-center                  x86_64 3.30.2-1.fc29     @updates   20 M
 gnome-control-center-filesystem       noarch 3.30.2-1.fc29     @updates    0  
 gnome-desktop3                        x86_64 3.30.2-1.fc29     @updates  2.6 M
 gnome-documents-libs                  x86_64 3.30.0-1.fc29     @anaconda 1.4 M
 gnome-icon-theme                      noarch 3.12.0-10.fc29    @anaconda 9.9 M
 gnome-keyring-pam                     x86_64 3.28.2-2.fc29     @anaconda  50 k
 gnome-menus                           x86_64 3.13.3-10.fc29    @anaconda 610 k
 gnome-online-miners                   x86_64 3.30.0-1.fc29     @anaconda 398 k
 gnome-remote-desktop                  x86_64 0.1.6-2.fc29      @updates  184 k
 gnome-session                         x86_64 3.30.1-2.fc29     @anaconda 1.5 M
 gnome-session-wayland-session         x86_64 3.30.1-2.fc29     @anaconda 7.4 k
 gnome-session-xsession                x86_64 3.30.1-2.fc29     @anaconda  15 k
 gnome-settings-daemon                 x86_64 3.30.1.2-2.fc29   @updates  5.2 M
 gnome-shell                           x86_64 3.30.2-1.fc29     @updates  7.4 M
 gnome-shell-extension-alternate-tab   noarch 3.30.1-1.fc29     @anaconda 9.4 k
 gnome-shell-extension-apps-menu       noarch 3.30.1-1.fc29     @anaconda  31 k
 gnome-shell-extension-common          noarch 3.30.1-1.fc29     @anaconda 593 k
 gnome-shell-extension-launch-new-instance
                                       noarch 3.30.1-1.fc29     @anaconda 4.9 k
 gnome-shell-extension-places-menu     noarch 3.30.1-1.fc29     @anaconda  26 k
 gnome-shell-extension-window-list     noarch 3.30.1-1.fc29     @anaconda  55 k
 gnome-themes-extra                    x86_64 3.28-2.fc29       @anaconda 4.3 M
 gnome-video-effects                   noarch 0.4.3-4.fc29      @anaconda 202 k
 gom                                   x86_64 0.3.3-7.fc29      @anaconda 177 k
 grilo-plugins                         x86_64 0.3.8-1.fc29      @anaconda 2.5 M
 gsound                                x86_64 1.0.2-7.fc29      @anaconda  82 k
 gtkspell3                             x86_64 3.0.10-1.fc29     @anaconda 121 k
 highlight                             x86_64 3.48-1.fc29       @updates  3.4 M
 iio-sensor-proxy                      x86_64 2.5-1.fc29        @updates  128 k
 libgcab1                              x86_64 1.1-3.fc29        @anaconda 205 k
 libgdither                            x86_64 0.6-18.fc29       @anaconda  45 k
 libgepub                              x86_64 0.6.0-2.fc29      @anaconda  84 k
 libreofficekit                        x86_64 1:6.1.2.1-4.fc29  @updates  226 k
 libsmbios                             x86_64 2.4.2-2.fc29      @anaconda 327 k
 libzapojit                            x86_64 0.0.3-14.fc29     @anaconda 119 k
 mutter                                x86_64 3.30.2-2.fc29     @updates   12 M
 redhat-menus                          noarch 12.0.2-14.fc29    @anaconda 675 k
 rpm-ostree-libs                       x86_64 2018.10-1.fc29    @updates  6.3 M
 switcheroo-control                    x86_64 1.1-6.fc29        @anaconda  58 k
 totem                                 x86_64 1:3.30.0-1.fc29   @updates  7.7 M
 vino                                  x86_64 3.22.0-11.fc29    @koji-override-0
                                                                          2.0 M
 xorg-x11-server-Xwayland              x86_64 1.20.3-2.fc29     @updates  2.4 M

Transaction Summary
================================================================================
Remove  77 Packages

Freed space: 250 M


Expected results:
just remove font itself

Additional info:

There is another black-white emoji font: google-noto-emoji-fonts

https://apps.fedoraproject.org/packages/google-noto-emoji-fonts
shows below

Package Tree
google-noto-emoji-fonts
|——google-noto-emoji-color-fonts

But dnf install google-noto-emoji-fonts won't install the color one, 'remove' the same.

---

btw, my emojis in Chrome and VSCode break. This's a bug or feature in Chrome?

Comment 1 Peng Wu 2019-01-02 06:25:07 UTC
I think GNOME requires one color emoji font.

For chrome issue, please provide screenshot or ask chrome.

Comment 2 lonr 2019-01-02 06:32:12 UTC
(In reply to Peng Wu from comment #1)
> I think GNOME requires one color emoji font.
> 
> For chrome issue, please provide screenshot or ask chrome.

Thanks


Note You need to log in before you can comment on or make changes to this bug.