Bug 166268 - KDM allows all users to shut down the system
KDM allows all users to shut down the system
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-18 10:07 EDT by Jason Tibbitts
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-18 10:28:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kdmrc file (966 bytes, text/plain)
2005-08-19 11:52 EDT, Jason Tibbitts
no flags Details

  None (edit)
Description Jason Tibbitts 2005-08-18 10:07:38 EDT
Using KDM from kdebase-3.4.2-0.fc3.2, with "AllowFifo=false" and
"AllowShutdown=Root" in the "[Shutdown]" and "[X-*-Core]" sections of
/etc/X11/xdm/kdmrc, respectively, I find that any user can power off or reboot
the system from the greeter and users are prompted to shutdown or restart the
system when they log out of KDE.
Comment 1 Ngo Than 2005-08-18 10:28:19 EDT
Yes, it's the KDE default setting. Every local user can shuttdown or reboot the
machine, but remote, only root is allowed to do this.

I don't think it will make sense to change it. because every local user could
switch off the machine!


Comment 2 Jason Tibbitts 2005-08-18 10:36:49 EDT
I'm confused.  Are you saying that the default setting can no longer be
overriden by AllowFifo=false and AllowShutdown=Root in /etc/X11/xdm/kdmrc as in
previous versions and as currently documented in the KDM manual?

I understand about default settings, but I have overridden them in the
documented and previously working manner.
Comment 3 Ngo Than 2005-08-18 10:52:21 EDT
what do you mean here? sorry, i don't understand your problem! could you please
give more infos about the problem? Thanks

Comment 4 Jason Tibbitts 2005-08-19 11:51:53 EDT
OK, let's try this.  I use KDM.  I don't want users to be able to shut down the
system without the root password, and I don't want them to be prompted to shut
down the system when they log out.  I understand that these are not the defaults.

So I read the KDM documentation, and I am informed that I can place, in the
"[Shutdown]" section of /etc/X11/xdm/kdmrc, the following line:

AllowFifo=false

and users will not be prompted to shut down the system when they log out.  I am
also informed that I can place, in the "[X-*-Core]" section of kdmrc, the
following line:

AllowShutdown=Root

and users will be prompted for the root password before being permitted to shut
down the machine.

I have made both of these additions.  They do not alter the behavior of KDM even
though according the documentation they should prevent users from shutting down
the system.  In previous versions they performed as documented; it was only ater
the update to kdebase-3.4.2-0.fc3.2 that they stopped working.

I will attach my kdmrc file.
Comment 5 Jason Tibbitts 2005-08-19 11:52:30 EDT
Created attachment 117919 [details]
kdmrc file
Comment 6 Jason Tibbitts 2005-08-19 14:56:42 EDT
I must apologize; I realized that AllowShutdown=Root does work; it just prompts
differently than previous KDM versions.  However, AllowFifo=false does indeed
not function.  However, if I use "FifoDir=" in the "[General]" section, the
command FIFO is completely disabled.  This does have the effect of preventing
users from shutting down the machine when they log out, which is sufficient for
my needs.  It does also disable everything else that uses the FIFO, however.

So my immediate problem is solved, but I still think there's a bug with AllowFifo.

Note You need to log in before you can comment on or make changes to this bug.