Bug 1662688 - pyqtrailer: Remove (sub)packages from Fedora 30+: python2-pyqtrailer
Summary: pyqtrailer: Remove (sub)packages from Fedora 30+: python2-pyqtrailer
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pyqtrailer
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PY2REMOVAL
TreeView+ depends on / blocked
 
Reported: 2018-12-31 16:20 UTC by Miro Hrončok
Modified: 2019-01-14 13:32 UTC (History)
1 user (show)

Fixed In Version: pyqtrailer-0.6.2-18.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-14 13:32:24 UTC


Attachments (Terms of Use)

Description Miro Hrončok 2018-12-31 16:20:20 UTC
In line with the Mass Python 2 Package Removal [0], the following (sub)packages of pyqtrailer were marked for removal:

 * python2-pyqtrailer

According to our query, those (sub)packages only provide a Python 2 importable module. If this is not true, please tell us why, so we can fix our query.

Please remove them from your package.

As said in the change document, if there is no objection in a week, we will remove the package(s) as soon as we get to it. This change might not match your packaging style, so we'd prefer if you did the change. If you need more time, please let us know here.

If you do the change yourself, it would help us a lot by reducing the amount of packages we need to mass change.

We hope this doesn't come to you as a surprise. If you want to know our motivation for this, please read the change document [0].

[0] https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal

Comment 1 Miro Hrončok 2018-12-31 16:21:20 UTC
Note that there is also /usr/bin/pyqtrailer but that can be AFAIK provided by what is now /usr/bin/pyqtrailer-3.

Comment 2 Miro Hrončok 2019-01-14 13:00:31 UTC
Fix ready, will push and build once pagure works.


Note You need to log in before you can comment on or make changes to this bug.