Bug 166272 - Bluecurve icon theme index file incomplete
Summary: Bluecurve icon theme index file incomplete
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-artwork   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-18 14:59 UTC by Matthias Clasen
Modified: 2013-03-13 04:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-22 18:40:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthias Clasen 2005-08-18 14:59:54 UTC
I investigated icon scaling a bit last night, and noticed that we continuously
scale down stock button images from 24x24 to 20x20, and mime type icons (for the
file chooser) from 48x48 to 16x16 - even though Bluecurve has 20x20 stock icons
and 16x16 mimetypes, they are just not mentioned in the index.theme file.

We should make sure that the index.theme file lists all subdirectories.
Doing that has 3 benefits:

a) less cycles wasted with scaling icons
b) less memory wasted, since we can use the unscaled icons from the cache,
   which are shared
c) possibly better icons, since the existing Bluecurve icons are probably
   not just scaled down versions

Comment 1 John (J5) Palmieri 2005-08-22 18:40:43 UTC
in rawhide shortly


Note You need to log in before you can comment on or make changes to this bug.