Bug 1662733 - Webadmin- Download 2 disks on a running VM fails but only 1 disk is shown in the error message
Summary: Webadmin- Download 2 disks on a running VM fails but only 1 disk is shown in ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.4.1
: 4.4.1.1
Assignee: Ahmad Khiet
QA Contact: Avihai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-01 08:15 UTC by Avihai
Modified: 2020-07-08 08:27 UTC (History)
4 users (show)

Fixed In Version: ovirt-engine-4.4.1.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-08 08:27:50 UTC
oVirt Team: Storage
pm-rhel: ovirt-4.4+
pm-rhel: ovirt-4.5?


Attachments (Terms of Use)
Video of the issue (591.05 KB, video/mp4)
2019-01-01 08:22 UTC, Avihai
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 108593 0 master MERGED webadmin: show all disks when download denied 2020-07-21 08:55:46 UTC
oVirt gerrit 108899 0 master MERGED Revert "webadmin: show all disks when download denied" 2020-07-21 08:55:46 UTC
oVirt gerrit 109134 0 master MERGED webadmin: show all disks when download denied 2020-07-21 08:55:46 UTC

Description Avihai 2019-01-01 08:15:07 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Avihai 2019-01-01 08:22:09 UTC
Description of problem:
Via UI(Webadmin) -> goto disks and download 2 disks on a running VM -> it fails as expected but only 1 disk is shown in the error message ( see video capture attached)

Version-Release number of selected component (if applicable):
Software Version:4.3.0-0.4.master.20181217152209.git3c9ccc7.el7

How reproducible:
100%

Steps to Reproduce:
1. Create VM and attach 2 disks to it
2. Start VM
3. Choose both disks and press on 'download' button.

Actual results:
it fails as expected but only 1 disk is shown in the error message ( see video capture attached)

the message is:
"Error while executing action: Cannot transfer Virtual Disk. The disk vm1_Disk1 is plugged to non-Down VMs: vm1"

Expected results:
Should fail but error message should show 2 disks

the message should be:
"Error while executing action: Cannot transfer Virtual Disks. The disks vm1_Disk1 and vm1_Disk2 are plugged to non-Down VMs: vm1"


Additional info:
See video capture for more details.

Comment 2 Avihai 2019-01-01 08:22:36 UTC
Created attachment 1517716 [details]
Video of the issue

Comment 3 Nir Soffer 2020-05-10 07:57:01 UTC
The fix for this change broke download from UI.

Comment 4 Nir Soffer 2020-05-10 09:23:26 UTC
Moving to NEW since the fix was reverted.

Comment 5 Avihai 2020-06-01 09:54:21 UTC
Verified on ovirt-engine 4.4.1.1-0.5.el8ev

Comment 6 Sandro Bonazzola 2020-07-08 08:27:50 UTC
This bugzilla is included in oVirt 4.4.1 release, published on July 8th 2020.

Since the problem described in this bug report should be resolved in oVirt 4.4.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.