Bug 1662862 - Realtek RTL8111/8168/8411 on 4.19.12-200 & 4.19.10-200 not working ok on 4.18.16-200
Summary: Realtek RTL8111/8168/8411 on 4.19.12-200 & 4.19.10-200 not working ok on 4.18...
Keywords:
Status: CLOSED DUPLICATE of bug 1650984
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 28
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-02 09:04 UTC by malc996
Modified: 2019-01-02 12:47 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-02 12:47:19 UTC
Type: Bug


Attachments (Terms of Use)

Description malc996 2019-01-02 09:04:00 UTC
Description of problem:
dnf update on 2nd January 2019 (and previously 1st Jan 2019) stopped the network  functionality.

07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 01) on the last two kernels is not working, but ok on earlier kernels, specifically:-
    Linux 4.18.16-200.fc28.x86_64  OK
    Linux 4.19.12-200 & 4.19.10-200 not working

systemctl network restart, runs without error but there is no external connectivity, ie can't ping other machines on the network but can pin the local IP, suggesting the network stack is good but card driver not working

Version-Release number of selected component (if applicable):
see above

How reproducible:
   Fails every time with new kernal, simply revert to earlier kernel and the network works

Steps to Reproduce:
1. dnf update
2. reboot > no network
3. reboot and select old kernel > network OK

Actual results:
   no network connectivity

Expected results:
   network connectivity

Additional info:
    Will probably move to FC29 to see if that fixes the problem

Comment 1 malc996 2019-01-02 11:02:17 UTC
Just tried upgrade to FC29 and see the same problem, will log separate bug for that

Comment 2 Hans de Goede 2019-01-02 12:47:19 UTC
I believe this is a duplicate of bug 1650984. Please try the 4.19.13 kernel from updates-testing which contains a workaround for bug 1650984.

*** This bug has been marked as a duplicate of bug 1650984 ***


Note You need to log in before you can comment on or make changes to this bug.