Bug 1662865 - oc new-app return error when interact with service-catalog
Summary: oc new-app return error when interact with service-catalog
Keywords:
Status: CLOSED DUPLICATE of bug 1671528
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Templates
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Adam Kaplan
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-02 09:23 UTC by Jian Zhang
Modified: 2019-03-12 14:24 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-01 15:52:42 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 1 Jian Zhang 2019-01-31 09:15:18 UTC
Any update for it?

Comment 2 Zihan Tang 2019-02-22 07:35:44 UTC
I also find the same issue in v4.0
error: no kind "ServiceInstance" is registered for version "servicecatalog.k8s.io/v1beta1" in scheme "k8s.io/kubernetes/pkg/kubectl/scheme/scheme.go:28"

This bug has been reported and fixed in v3.11 https://bugzilla.redhat.com/show_bug.cgi?id=1610255
It's oc command line issue. Assign to Command Line Interface.

Comment 3 Maciej Szulik 2019-03-01 14:00:51 UTC
Devexp team should re-write new-app, I've created https://jira.coreos.com/browse/DEVEXP-285 to track it.

Comment 4 Ben Parees 2019-03-01 15:52:42 UTC

*** This bug has been marked as a duplicate of bug 1671528 ***


Note You need to log in before you can comment on or make changes to this bug.