Bug 166291 - Make menuconfig does not display correctly (ncurses?)
Make menuconfig does not display correctly (ncurses?)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ncurses (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Petr Raszyk
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-18 15:52 EDT by Joe Dupre
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-30 09:14:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joe Dupre 2005-08-18 15:52:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)

Description of problem:
When configuring software that uses "make menuconfig" and wants to draw the extended ASCII "line" characters (busybox, uClibc or buildroot, for example), the display does not look right (it is "blocky" and "flat" (2 dimmensional), and sometimes does weird things that makes it hard to use (like having text from a previous screen appear when navigating into a menu tree)).  The issue is that menuconfig should be drawing the special "line" characters, but it is not. I have noticed this on fc3 and fc4.

When I do the same thing on RH 7.3 or a "Linux From Scratch" build, the display is correct:  It has shadowed areas of the screen, and nice clean lines as borders.

I assume that this has something to do with ncurses, or perhaps supported character sets.  

Version-Release number of selected component (if applicable):
ncurses-5.4

How reproducible:
Always

Steps to Reproduce:
1.  download buildroot-x.x.x (http://buildroot.uclibc.org/downloads/snapshots/)
2.  tar jxvf buildroot* && cd buildroot 
3.  make menuconfig
  

Actual Results:  Ugly malfuctioning configuration menues.

Expected Results:  Nice clean configuration menues.

Additional info:

Observed on FC3 and FC4.

RH9 returns an error:
usr/bin/ld: cannot find -lncurses
(Even though ncurses 5.3 is installed.)

Works as expected on RH 7.3
Comment 1 Petr Raszyk 2005-08-30 09:12:40 EDT
It can be depend on many things:
  a) terminal emulator type
  b) selected font
  c) LANG environment variable
  d) TERM environment variable
  e) TERMINFO environment variable
  f) how your application is writen (ncurses or slang).

We have tried your issue using 'xterm'
(Launch 'xterm' and set some shell-environment-variables
at the command prompt of this new 'xterm'):

1) Launch (at command prompt)             :  xterm -fn 8x16
2) Set shell-environment-variable LANG    :  export LANG=en_US
3) Set shell-environment-variable TERM    :  export TERM=xterm
4) Set shell-environment-variable TERMINFO:  export TERMINFO=/usr/share/terminfo
5) Launch (in the corresponding directory):  make menuconfig

Expected Results:  Nice clean configuration menues.
Your application probably uses ncurses-library. This
library does not support UTF-8 fonts. A UTF-8 font
needs slang-library.

NOTE: Not every terminal is able to support UTF-8 encoding.
      Not every 'selected font' contains 'extended ACSII'
      characters (ACS_HLINE, ACS_VLINE, ...).
      Use shell-environment-variable LD_LIBRARY_PATH to help
      the dynamic-loader to find curses/ncurses library.
      Example:  export LD_LIBRARY_PATH=/lib:/usr/lib
              
             
Petr Raszyk

Note You need to log in before you can comment on or make changes to this bug.