Bug 1662923 - [downstream clone - 4.2.8] Old 'Intel Haswell Family-IBRS' cluster CPU type not renamed during the upgrade
Summary: [downstream clone - 4.2.8] Old 'Intel Haswell Family-IBRS' cluster CPU type n...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.2.8
: ---
Assignee: Michal Skrivanek
QA Contact: Liran Rotenberg
URL:
Whiteboard:
Depends On: 1633645
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-02 12:39 UTC by RHV Bug Bot
Modified: 2019-01-22 12:45 UTC (History)
6 users (show)

Fixed In Version: ovirt-engine-4.2.8.2
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Previous Red Hat Virtualization installations of 3.6 ELS and 4.1 introduced "Intel Haswell Family-IBRS" Cluster CPU type for Meltdown/Spectre mitigations. Red Hat Virtualization 4.2 refers to this CPU type as "Intel Haswell IBRS Family." This release updates the CPU type name and the previous name updates automatically on upgrade.
Clone Of: 1633645
Environment:
Last Closed: 2019-01-22 12:45:05 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0121 None None None 2019-01-22 12:45:07 UTC
oVirt gerrit 94567 master MERGED engine: rename 'Intel Haswell Family-IBRS' CPU type 2019-01-02 12:39:28 UTC
oVirt gerrit 96576 ovirt-engine-4.2 MERGED engine: rename 'Intel Haswell Family-IBRS' CPU type 2019-01-07 09:16:21 UTC

Description RHV Bug Bot 2019-01-02 12:39:17 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1633645 +++
======================================================================

Description of problem:

Older 'Intel Haswell Family-IBRS' cluster CPU type is not renamed to the new name 'Intel Haswell IBRS Family' during the upgrade 


Version-Release number of selected component (if applicable):
4.2.6

How reproducible:
Always

Steps to Reproduce:
1. Perform an RHEV 3.6 ELS installation and configure the cluster CPU type as 'Intel Haswell Family-IBRS'
2. Upgrade to latest RHV 4.2

Actual results:

The cluster CPU type is not updated to 'Intel Haswell IBRS Family' and changing cluster 'CPU Type' is not possible using the web administration portal  


Expected results:

The cluster CPU type is updated to 'Intel Haswell IBRS Family' during the upgrade.


Additional info:

'Intel Haswell Family-IBRS' CPU type was introduced in rhevm-setup-plugins-3.6.7 (RHEV 3.6 ELS)

Since version 4.2.1.4 all the CPU types were renamed on the upgrade (packaging/dbscripts/upgrade/04_02_0930_fix_skylake_cpu_name.sql) to the new names but there is no match for this name and is left unchanged.

(Originally by Miguel Martin Villamuelas)

Comment 1 RHV Bug Bot 2019-01-02 12:39:19 UTC
Not sure why this didn't move automatically

(Originally by Ryan Barry)

Comment 2 RHV Bug Bot 2019-01-02 12:39:20 UTC
WARN: Bug status (ON_QA) wasn't changed but the folowing should be fixed:

[Found non-acked flags: '{'rhevm-4.3-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status (ON_QA) wasn't changed but the folowing should be fixed:

[Found non-acked flags: '{'rhevm-4.3-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.com

(Originally by rhv-bugzilla-bot)

Comment 3 RHV Bug Bot 2019-01-02 12:39:22 UTC
this needs to be backported for 3.6 and 4.1 installations upgrading to 4.2 when using this type. The fix is only relevant to RHV

(Originally by michal.skrivanek)

Comment 4 Liran Rotenberg 2019-01-14 11:16:19 UTC
Verified on:
ovirt-engine-4.2.8.2-0.1.el7ev.noarch

Steps:
1. Deployed RHEV 4.1.
2. Set the cluster type to: Intel Haswell Family-IBRS.
3. Upgrade to RHEV 4.2.
4. Check the cluster's CPU type. 

Results:
The cluster CPU type stayed as expected: Intel Haswell IBRS Family.

Comment 6 errata-xmlrpc 2019-01-22 12:45:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0121


Note You need to log in before you can comment on or make changes to this bug.