Bug 1662992 - When running openshift_certificate_expiry playbook get "The conditional check 'not openshift_is_atomic | bool' failed"
Summary: When running openshift_certificate_expiry playbook get "The conditional check...
Keywords:
Status: CLOSED DUPLICATE of bug 1655183
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-02 16:38 UTC by emahoney
Modified: 2019-01-03 14:43 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-03 14:43:55 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description emahoney 2019-01-02 16:38:35 UTC
Description of problem:
When running the openshift_certificate_expiry playbook after updating to v3.11.43, the playbook fails with the below errors on all hosts:

~~~
TASK [openshift_certificate_expiry : Ensure python dateutil library is present] ****************************************************
task path: /usr/share/ansible/openshift-ansible/roles/openshift_certificate_expiry/tasks/main.yml:2
fatal: [hostc]: FAILED! => {
    "msg": "The conditional check 'not openshift_is_atomic | bool' failed. The error was: error while evaluating conditional (not openshift_is_atomic | bool): 'openshift_is_atomic' is undefined\n\nThe error appears to have been in '/usr/share/ansible/openshift-ansible/roles/openshift_certificate_expiry/tasks/main.yml': line 2, column 3, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n---\n- name: Ensure python dateutil library is present\n  ^ here\n"
}
~~~

Looks very similar to this 3.10 BZ: 
https://bugzilla.redhat.com/show_bug.cgi?id=1563132

Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

[user@hostc ~]$ oc version
oc v3.11.43
kubernetes v1.11.0+d4cacc0
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://master.lab.example.com:8443
openshift v3.11.43
kubernetes v1.11.0+d4cacc0
[user@hostc ~]$ rpm -q openshift-ansible
openshift-ansible-3.11.43-1.git.0.fa69a02.el7.noarch


How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results: Will attach playbook output. 
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results: Playbook runs without error

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 2 Scott Dodson 2019-01-03 14:43:55 UTC

*** This bug has been marked as a duplicate of bug 1655183 ***


Note You need to log in before you can comment on or make changes to this bug.