Bug 1663011 - clamav-devel-0.101 unusable due to missing cltypes.h
Summary: clamav-devel-0.101 unusable due to missing cltypes.h
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: clamav
Version: 28
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Sergio Monteiro Basto
QA Contact: Fedora Extras Quality Assurance
URL: https://blog.clamav.net/2018/12/libcl...
Whiteboard:
Depends On:
Blocks: 1604507 1663331 1665739
TreeView+ depends on / blocked
 
Reported: 2019-01-02 17:20 UTC by Kevin Kofler
Modified: 2019-01-22 02:05 UTC (History)
12 users (show)

Fixed In Version: clamav-0.101.0-3.fc29 clamav-0.101.1-1.fc29 clamav-0.101.1-1.fc28 clamav-0.101.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-13 02:31:14 UTC


Attachments (Terms of Use)

Description Kevin Kofler 2019-01-02 17:20:51 UTC
Description of problem:
I cannot rebuild klamav (kdelibs3 UI for ClamAV) against the current ClamAV soname because clamav-devel is missing a header (cltypes.h) included by /usr/include/clamav.h itself.

Version-Release number of selected component (if applicable):
clamav-devel-0.101.0-1.fc28.x86_64
clamav-devel-0.101.0-1.fc29.x86_64
clamav-devel-0.101.0-1.fc30.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Try building the current klamav from dist-git on any supported Fedora release (F28+).

Actual results:
BUILDSTDERR: In file included from options.c:25:
BUILDSTDERR: /usr/include/clamav.h:68:10: fatal error: cltypes.h: No such file or directory
BUILDSTDERR:  #include "cltypes.h"
BUILDSTDERR:           ^~~~~~~~~~~
BUILDSTDERR: compilation terminated.

Expected results:
cltypes.h is installed, because clamav.h needs it.

Additional info:
For F28, this is a regression in an update.

Comment 1 Kevin Kofler 2019-01-02 19:12:11 UTC
This is the fix that is required:
https://github.com/Cisco-Talos/clamav-devel/commit/dee22f2acf5e322c24ff5df4b6606f93eac5690e

Comment 2 Jason Tibbitts 2019-01-03 22:41:57 UTC
So it seems that clamav 0.101 bumps from libclamav.7 to libclamav.9.  Since it's already been pushed, all of the packages that depend on libclamav need rebuilding, but currently nothing that includes clamav.h can build at all.

Here's hoping that clamav upstream release 0.101.1 sooner rather than later.  They said "shortly after the start of 2019".

Comment 3 Kevin Kofler 2019-01-03 23:12:11 UTC
I'd suggest just backporting the patch from git (see comment #1).

Comment 4 Kevin Kofler 2019-01-03 23:13:13 UTC
By the way, this soname bump was pushed all the way down to F28 updates (!) and was NOT announced, neither to the mailing list, nor to me (whereas an announcement is mandatory even for Rawhide!).

Comment 5 Orion Poplawski 2019-01-03 23:46:43 UTC
Yeah, I messed up big here.  Working on an update.

Comment 6 Sergio Monteiro Basto 2019-01-03 23:49:32 UTC
when 0.101.1 is released ?

Comment 7 Jason Tibbitts 2019-01-03 23:51:13 UTC
Supposedly "shortly after the start of 2019".  Which to me means, uh, today or maybe tomorrow.  But other than that one blog post I haven't seen any other news.

Comment 8 Orion Poplawski 2019-01-04 00:01:33 UTC
Updated clamav building for rawhide - https://koji.fedoraproject.org/koji/taskinfo?taskID=31799599  will try to rebuild deps after that completes.

Comment 9 Jason Tibbitts 2019-01-04 00:06:59 UTC
I don't think cyrus-imapd will build in rawhide right now even with this fix, so don't worry about doing that one.

Comment 10 Orion Poplawski 2019-01-04 01:24:55 UTC
Well, perhaps not unsurprising for an ABI change, there are API changes as well.  So both klamav and cyrus-imapd will need to be updated to handle them.

Comment 11 Kevin Kofler 2019-01-04 03:34:32 UTC
I got klamav building in Rawhide: https://koji.fedoraproject.org/koji/buildinfo?buildID=1177040
I want to build that for F28 updates and F29 updates too, but I need a working clamav buildroot override for that.

Comment 12 Orion Poplawski 2019-01-04 15:42:53 UTC
Buildroot overrides have just been submitted.

Comment 13 Kevin Kofler 2019-01-04 15:52:30 UTC
And now they entered the buildroots (according to koji wait-repo), so I submitted the klamav builds.

Comment 14 Kevin Kofler 2019-01-04 16:30:17 UTC
For F28, there is a "build key" mismatch between qt3 and kdelibs3, so I am rebuilding kdelibs3 too.

Comment 16 Fedora Update System 2019-01-04 19:34:36 UTC
clamav-0.101.0-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-a3cadfdac5

Comment 17 Fedora Update System 2019-01-04 19:34:41 UTC
clamav-0.101.0-3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-f1d3e0edd3

Comment 18 Fedora Update System 2019-01-04 19:34:45 UTC
clamav-0.101.0-3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-313b5e92f4

Comment 19 Fedora Update System 2019-01-05 01:44:58 UTC
clamav-0.101.0-3.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-313b5e92f4

Comment 20 Fedora Update System 2019-01-05 02:17:05 UTC
clamav-0.101.0-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-a3cadfdac5

Comment 21 Fedora Update System 2019-01-05 18:51:54 UTC
clamav-0.101.0-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-f1d3e0edd3

Comment 22 Fedora Update System 2019-01-07 02:36:03 UTC
clamav-0.101.0-3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Frank Crawford 2019-01-09 09:38:29 UTC
(In reply to Jason Tibbitts from comment #2)
> So it seems that clamav 0.101 bumps from libclamav.7 to libclamav.9.  Since
> it's already been pushed, all of the packages that depend on libclamav need
> rebuilding, but currently nothing that includes clamav.h can build at all.
> 
> Here's hoping that clamav upstream release 0.101.1 sooner rather than later.
> They said "shortly after the start of 2019".

FYI, it looks like 0.101.1 was released yesterday.

Comment 24 Sergio Monteiro Basto 2019-01-09 17:42:17 UTC
(In reply to Frank Crawford from comment #23)

> FYI, it looks like 0.101.1 was released yesterday.

Thanks, upstream-release-monitoring seems that is stopped since 28 of Dec 2018 .

Anyone want take care of update ? or should I take it ? 

Thanks

Comment 25 Orion Poplawski 2019-01-09 17:43:35 UTC
If you could handle it, that would be great.  Thanks.

Comment 26 Sergio Monteiro Basto 2019-01-10 04:24:38 UTC
OK , I'm preparing a new package

Comment 27 Fedora Update System 2019-01-10 13:52:24 UTC
clamav-0.101.1-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a96a482d2e

Comment 28 Fedora Update System 2019-01-10 13:52:46 UTC
clamav-0.101.1-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-7e3eae1b62

Comment 29 Fedora Update System 2019-01-10 13:53:08 UTC
clamav-0.101.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-95a6047bc6

Comment 30 Fedora Update System 2019-01-11 03:28:53 UTC
clamav-0.101.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-95a6047bc6

Comment 31 Fedora Update System 2019-01-11 04:16:57 UTC
clamav-0.101.1-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a96a482d2e

Comment 32 Fedora Update System 2019-01-11 05:42:51 UTC
clamav-0.101.1-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-7e3eae1b62

Comment 33 Fedora Update System 2019-01-13 02:31:14 UTC
clamav-0.101.1-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 34 Fedora Update System 2019-01-15 01:53:25 UTC
clamav-0.101.1-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 35 Fedora Update System 2019-01-22 02:05:39 UTC
clamav-0.101.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.