Bug 1663038 - Dashboard Pie Chart widgets odd behavior
Summary: Dashboard Pie Chart widgets odd behavior
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Dashboard
Version: 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 3.*
Assignee: Alfonso Martínez
QA Contact: Uday kurundwade
Anjana Suparna Sriram
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-02 19:42 UTC by Ju Lim
Modified: 2019-01-03 13:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-03 13:49:35 UTC
Target Upstream Version:


Attachments (Terms of Use)
raw capacity - before any selection made (165.39 KB, image/jpeg)
2019-01-02 19:42 UTC, Ju Lim
no flags Details
raw capacity - both items selected and pie chart disappears (93.13 KB, image/jpeg)
2019-01-02 19:43 UTC, Ju Lim
no flags Details
raw capacity - avail selected (color changed from blue to pink) (5.89 MB, image/jpeg)
2019-01-02 19:45 UTC, Ju Lim
no flags Details
pg status - before any selection made (6.61 MB, image/jpeg)
2019-01-02 19:46 UTC, Ju Lim
no flags Details
pg status - selected item disappears (121.33 KB, image/jpeg)
2019-01-02 19:46 UTC, Ju Lim
no flags Details

Description Ju Lim 2019-01-02 19:42:58 UTC
Created attachment 1518023 [details]
raw capacity - before any selection made

Description of problem:
When clicking on the legend of the pie charts, I'm observing some unusual behavior.  (1) Specifically, when you click on an item in the legend, it crosses out (strickthrough) the item in the legend.
(2) Sometimes it changes the color of the slice you are selecting (e.g. blue to pink).
(3) User seems to be able to select multiple items in the legends, which crosses out (strike through) all the items you selected.


Version-Release number of selected component (if applicable):
3.2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Ju Lim 2019-01-02 19:43:59 UTC
Created attachment 1518024 [details]
raw capacity - both items selected and pie chart disappears

Comment 4 Ju Lim 2019-01-02 19:45:50 UTC
Created attachment 1518025 [details]
raw capacity - avail selected (color changed from blue to pink)

Comment 5 Ju Lim 2019-01-02 19:46:25 UTC
Created attachment 1518026 [details]
pg status - before any selection made

Comment 6 Ju Lim 2019-01-02 19:46:54 UTC
Created attachment 1518027 [details]
pg status - selected item disappears

Comment 7 Ju Lim 2019-01-03 13:47:39 UTC
Per chatting with Alfonso, the pie charts are working as expected per how the ChartJS pie chart widgits.  See https://www.chartjs.org/docs/latest/charts/doughnut.html for more details.

If user clicks on a legend item, user is deselecting/hiding/filtering this slice, and if there is no data for a slice, it is not shown.
There is no color change -- when there is only1 slice it gets the whole pie.

From UX perspective, the behavior is confusing.  Possible solutions includes disabling legend click/selection; however, there are concerns with doing so as it would be hard for users to click on a very thin slice.

For now, let's leave this as-is and if we have enough user/customer feedback, we'll revisit it.


Note You need to log in before you can comment on or make changes to this bug.