Bug 1663125 - restraint can't start when ipv6 is disabled
Summary: restraint can't start when ipv6 is disabled
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Restraint
Classification: Retired
Component: general
Version: 0.1.36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: 0.1.37
Assignee: Bill Peck
QA Contact:
URL:
Whiteboard:
: 1663460 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-03 09:21 UTC by Jianlin Shi
Modified: 2019-01-28 10:10 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-09 13:17:26 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Beaker Project Gerrit 6360 0 None None None 2019-01-07 16:25:58 UTC

Description Jianlin Shi 2019-01-03 09:21:06 UTC
Description of problem:
restraint can't start when ipv6  is disabled

Version-Release number of selected component (if applicable):
beaker-26.2
restraint-0.1.36-1.git.2.4e1c859.el8

How reproducible:
Always

Steps to Reproduce:
1. disable ipv6 and reboot

Actual results:
restraint fail to start

Expected results:
restraint can start

Additional info:

as following job shows:

https://beaker.engineering.redhat.com/jobs/3268809

systemctl status restraintd
● restraintd.service - The restraint harness.
  Loaded: loaded (/usr/lib/systemd/system/restraintd.service; enabled; vendor preset: disabled)
  Active: failed (Result: exit-code) since Thu 2019-01-03 03:43:39 EST; 4min 2s ago
Main PID: 14875 (code=exited, status=1/FAILURE)

Comment 1 Bill Peck 2019-01-04 15:18:45 UTC
*** Bug 1663460 has been marked as a duplicate of this bug. ***

Comment 2 Bill Peck 2019-01-04 15:20:17 UTC
on the console you will see the following message:
restraintd[1757]: Unable to bind to server port 8081

Comment 3 Jianlin Shi 2019-01-06 09:03:59 UTC
(In reply to Bill Peck from comment #2)
> on the console you will see the following message:
> restraintd[1757]: Unable to bind to server port 8081

I also noticed the error, the reason why I created the bug is that I want to know how can restraint start with ipv6 disabled

Comment 4 Bill Peck 2019-01-07 12:55:42 UTC
I wasn't discounting the bug, just providing more info about when it's seen.

Comment 5 Jianlin Shi 2019-01-11 01:04:19 UTC
Hi Bill,

As we QE are required to run tests with ipv6 disabled.  is there any work around before the next release is ready?
if not, when will the next release become ready? we are in snapshot 4 of RHEL8, it's better to get it ready before
rhel8 RC.

Comment 6 Martin Styk 2019-01-11 07:04:11 UTC
Hello Jianlin,

I will try to answer your questions.
1. As far as I know, due to the implementation of Restraint, it is not possible to make a workaround for the current situation (0.1.36)
2. I'm starting preparation for the new release of Restraint today. Hopefully, we will be able to ship it today/next week when everything will be settled after the outage.

Comment 7 Jianlin Shi 2019-01-11 07:07:19 UTC
(In reply to Martin Styk from comment #6)
> Hello Jianlin,
> 
> I will try to answer your questions.
> 1. As far as I know, due to the implementation of Restraint, it is not
> possible to make a workaround for the current situation (0.1.36)
> 2. I'm starting preparation for the new release of Restraint today.
> Hopefully, we will be able to ship it today/next week when everything will
> be settled after the outage.
That's great, so we can use the new release in rhel8 RC testing.

please update here after the new release is shipped, thanks

Comment 8 Martin Styk 2019-01-28 10:10:37 UTC
Restraint 0.1.37 has been released.


Note You need to log in before you can comment on or make changes to this bug.