Bug 1663173 - navigating to non existing content view displays all versions of all content views
Summary: navigating to non existing content view displays all versions of all content ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Views
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-03 11:14 UTC by Roman Plevka
Modified: 2020-02-03 16:27 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-03 16:27:49 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Roman Plevka 2019-01-03 11:14:00 UTC
Description of problem:
navigating to
https://<satellite_server>/content_views/<id of non existing CV>

only shows a popup with 404, but allows user to load the page with no details. when user navigates to the <versions> tab, he can see all versions of all content views (even belonging to other orgs).

Version-Release number of selected component (if applicable):
6.5.0-8

How reproducible:
always

Steps to Reproduce:
1. create multiple orgs and create+publish a content view in each of them
2. navigate to one of them and remove it (you get to remove the published versions first)
[3.a] the page shows a popup of CV being deleted, however it does not refresh the page, so you can still see the CV record in the table
[3.b] click it
[4] or simply navigate to /content_views/<nonexisting id>/
5. 404 pops up, but you still get to the CV details page
6. navigate to <versions> tab and explore all the versions of all the CVs created in different orgs

Actual results:


Expected results:


Additional info:

Comment 3 Bryan Kearney 2020-01-15 21:00:33 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 4 Bryan Kearney 2020-02-03 16:27:49 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.