Bug 1663205 - List dictionary is too slow
Summary: List dictionary is too slow
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: GlusterFS
Classification: Community
Component: fuse
Version: 4.1
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-03 12:22 UTC by xs233
Modified: 2020-03-12 12:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-12 12:33:50 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description xs233 2019-01-03 12:22:53 UTC
Description of problem:
I create a distribute volume and mount to a dictionary. Then I put 25,000 files to the dictionary. After finished, I write a program to list the dictionary. I found the program spent 20s. It's unbelievable. And I copy the dictionary to root dictionary. And running the program again. The time display just less than 1s. So I think there is some problems in glusterFS. Then I do some more test for glusterFS. I found that the spent time is normal when the dictionary contains 20,000 files, but when the number is more than 20,000, it's easy to show bad performance. Finally, I found the reason of bad performance is stat function for every file. I don't know why the stat function is spent lots of time when the dictionary contains 25,000 files. I hope someone can help me.

GlusterFS vesion:
glusterfs 4.1.6

Volume info:
Volume Name: gv0
Type: Distribute
Volume ID: 7cfccb92-5b9d-4483-8212-0f02cd1197d6
Status: Started
Snapshot Count: 0
Number of Bricks: 1
Transport-type: tcp
Bricks:
Brick1: dlaas-184:/data/glusterFS/gv0
Options Reconfigured:
transport.address-family: inet
nfs.disable: on

Comment 1 Worker Ant 2020-03-12 12:33:50 UTC
This bug is moved to https://github.com/gluster/glusterfs/issues/905, and will be tracked there from now on. Visit GitHub issues URL for further details


Note You need to log in before you can comment on or make changes to this bug.