This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 166321 - chkrootkit script doesn't pass arguments to real executable
chkrootkit script doesn't pass arguments to real executable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: chkrootkit (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Schwendt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-19 01:44 EDT by Jeremy C. Reed
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 10:00:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy C. Reed 2005-08-19 01:44:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.7.10) Gecko/20050721 Firefox/1.0.6

Description of problem:
Note my component above is wrong. The drop-down didn't provide my component. I installed it a couple times (on different Fedora Core 4 boxes) using yum from Red Hat repository. This bugzilla is taking me over ten minutes just to submit a simple bug fix. (And I do know bugzilla.) I assume others will give up before submitting a bug if it is this time consuming.

$ cat /usr/sbin/chkrootkit 
#! /bin/sh
cd /usr/lib/chkrootkit-0.45
./chkrootkit


Notice above last line is missing $*
Because of this bug command-line switches for chkrootkit are ignored.

Version-Release number of selected component (if applicable):
 chkrootkit-0.45-3

How reproducible:
Always

Steps to Reproduce:
1. Run "chkrootkit -l" and see it doesn't give you list of tests but actually
does the tests.
2.
3.
  

Actual Results:  It doesn't give you list of tests but actually
does the tests.

Expected Results:  $ /usr/lib/chkrootkit-0.45/chkrootkit -l
/usr/lib/chkrootkit-0.45/chkrootkit: tests: aliens asp bindshell lkm rexedcs sniffer w55808 wted scalper slapper z2 chkutmp amd basename biff chfn chsh cron date du dirname echo egrep env find fingerd gpm grep hdparm su ifconfig inetd inetdconf identd init killall ldsopreload login ls lsof mail mingetty netstat named passwd pidof pop2 pop3 ps pstree rpcinfo rlogind rshd slogin sendmail sshd syslogd tar tcpd tcpdump top telnetd timed traceroute vdir w write

Additional info:

Easy fix.

Or if you want it that way: Fix documentation.
Comment 1 Michael Schwendt 2005-08-19 10:00:43 EDT
chkrootkit-0.45-4.fc4 will fix this. Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.