Bug 1663232 - profile info command is not displaying information of bricks which are hosted on peers
Summary: profile info command is not displaying information of bricks which are hosted...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd
Version: rhgs-3.4
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: RHGS 3.4.z Batch Update 3
Assignee: Sanju
QA Contact: Nag Pavan Chilakam
URL:
Whiteboard:
Depends On: 1663223
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-03 14:16 UTC by Sanju
Modified: 2019-02-04 07:41 UTC (History)
10 users (show)

Fixed In Version: glusterfs-3.12.2-36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1663223
Environment:
Last Closed: 2019-02-04 07:41:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0263 0 None None None 2019-02-04 07:41:49 UTC

Description Sanju 2019-01-03 14:16:23 UTC
+++ This bug was initially created as a clone of Bug #1663223 +++

Description of problem:
When we run "gluster v profile <volname> info" from node n1, it is showing
information of bricks from local node only. Information of bricks which are hosted on peers is not shown in the output.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. In a cluster of more than 1 node, create and start a volume
2. start profile for the volume
3. run gluster v profile volname info

Actual results:


Expected results:
it should display information of all the bricks of volume.

Additional info:

--- Additional comment from Worker Ant on 2019-01-03 19:18:12 IST ---

REVIEW: https://review.gluster.org/21988 (glusterd: aggregate rsp from peers) posted (#1) for review on master by Sanju Rakonde

Comment 3 Atin Mukherjee 2019-01-03 14:50:25 UTC
This is a regression and has to be fixed.

Comment 10 errata-xmlrpc 2019-02-04 07:41:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0263


Note You need to log in before you can comment on or make changes to this bug.