RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1663264 - [RFE] rpm: Provide a way to strip binaries again if -g is specified
Summary: [RFE] rpm: Provide a way to strip binaries again if -g is specified
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpm
Version: 7.7
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Pavlina Moravcova Varekova
QA Contact: Eva Mrakova
Marie Hornickova
URL:
Whiteboard:
: 1982312 (view as bug list)
Depends On: 1661512
Blocks: 1661508
TreeView+ depends on / blocked
 
Reported: 2019-01-03 15:21 UTC by Florian Weimer
Modified: 2021-08-18 10:47 UTC (History)
12 users (show)

Fixed In Version: rpm-4.11.3-38.el7
Doc Type: Enhancement
Doc Text:
.New `--g-libs` option for the `find-debuginfo.sh` script This update introduces the new `--g-libs` option for the `find-debuginfo.sh` script. This new option is an alternative to previous `-g` option, which instructed the script to remove only debugging symbols from both binary and library files. The new `--g-libs` option works the same way as `-g`, but only for library files. The binary files are stripped completely.
Clone Of: 1661512
: 1980651 (view as bug list)
Environment:
Last Closed: 2019-08-06 13:11:23 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:2259 0 None None None 2019-08-06 13:11:37 UTC

Description Florian Weimer 2019-01-03 15:21:44 UTC
+++ This bug was initially created as a clone of Bug #1661512 +++

glibc relied on the behavior that bug 1186563 changed: We use -g, but do not want to apply it to programs.

It looks like this will need some find-debuginfo.sh change.  (I am not interested in a hack that puts custom binaries on PATH or something like that.)

Comment 2 Florian Weimer 2019-01-03 15:24:00 UTC
Based on bug 1661508 comment 2, I don't think we can achieve what we need with just glibc spec file changes, so we need some sort extension to find-debuginfo.sh.

Comment 3 Panu Matilainen 2019-01-04 08:49:19 UTC
So maybe we should consider reverting the rpm change instead. This was accepted into rhel-7 with the assumption that it was a simle and harmless backport, but instead we have a regression on glibc.

Btw, https://bugzilla.redhat.com/show_bug.cgi?id=1186563#c45 has some background on the -g thing.

Comment 4 Pavlina Moravcova Varekova 2019-01-04 12:27:07 UTC
Reverting of the patch looks as a good option.

Comment 43 errata-xmlrpc 2019-08-06 13:11:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2259

Comment 44 Michal Domonkos 2021-08-18 10:47:24 UTC
*** Bug 1982312 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.