Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1663309 - Receiving "Executive Reporting requires 10 or more systems to be registered with Insights" message when more than 10 systems are registered
Summary: Receiving "Executive Reporting requires 10 or more systems to be registered w...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Cloud Software Services (cloud.redhat.com)
Classification: Red Hat
Component: [Legacy] Insights Web UI
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Ken Hoes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-03 18:59 UTC by Danny Synk
Modified: 2019-11-01 03:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-12 17:18:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3935341 0 Configure None Getting error "Executive Reporting requires 10 or more systems to be registered with Insights. Please register10 more sy... 2019-03-22 15:16:00 UTC

Description Danny Synk 2019-01-03 18:59:56 UTC
Description of problem:

A customer has 73 systems registered to Insights. 13 of these systems are registered directly to the Insights portal; the remaining systems are proxied through a Satellite server. However, when they attempt to view the Executive report, they receive a message that reads:

"Executive Reporting requires 10 or more systems to be registered with Insights. Please register 9 more systems to enable reporting for your account."

This issue has persisted through the customer re-registering 10 of the systems to Insights as a test to see if the behavior changes. 

The user is an org admin. Other org admin users on the customer's account encounter the same behavior.


How reproducible:

Not reproducible thus far outside of the customer's account.


Actual results:

Customer is unable to view the Insights Executive Report.


Expected results:

Customer is able to view the Insights Executive Report.

Comment 4 ir. Jan Gerrit Kootstra 2019-03-22 15:39:41 UTC
I tried 4 different browsers: MS Edge, MS Internet Explorers, Google Chrome, and Mozilla Firefox.
All give the same result: Executive Reporting requires 10 or more systems to be registered with Insights.

We have 2 different RH Satellite 6.4.2 proxying in total 23 Insight clients + the 2 RH Satellite servers.

Comment 5 ir. Jan Gerrit Kootstra 2019-03-22 15:42:19 UTC
Executive Reporting requires 10 or more systems to be registered with Insights.
Please register6 more systems to enable reporting for your account.

Comment 6 Rob Williams 2019-03-22 15:53:52 UTC
Hey Jan,
Thanks Jan for trying this out with several browsers. We have identified that the underlying problem is on our end with our APIs which is why you consistently encounter the problem no matter which browser you are using. We're continuing to see what options we have to re mediate this problem.

Thanks,
Rob

Comment 7 ir. Jan Gerrit Kootstra 2019-03-22 16:15:23 UTC
Hey Rob,


The Knowledge Base article could give the impression that the issue is pure client based.

Stale clients is not an issues either in our case. All clients of one RH Satellite have been re-registered by hand. The other environment has been rebuild completely.
So all registrations are less then a month old.


Regards,


Jan Gerrit

Comment 8 Rob Williams 2019-03-22 16:47:14 UTC
Hi Jan,
Do you mind sending over the link to the KCS article you are referring to when you get a chance? I Wasn't aware one existed that was one associated to this issue. Happy to give it a review to ensure it's up to date with the latest clear and accurate information. 

The underlying problem we found out in our codebase was although it's asking for "10 systems" what it seems to be really looking for is 10 systems that have hits on them. This creates a problem because you could have 50 systems, all registered to Insights, but if < 10 of them have findings, it seems to restrict users from accessing the executive reports - not an ideal experience. We're still in the process of addressing that underlying issue.  

Thanks,
Rob Williams
Product Manager - Red Hat Insights

Comment 9 ir. Jan Gerrit Kootstra 2019-03-22 16:52:10 UTC
https://access.redhat.com/solutions/3935341
Getting error "Executive Reporting requires 10 or more systems to be registered with Insights. Please register10 more systems to enable reporting for your account." while accessing the Executive Reports in Insights. 

Solution In Progress - Updated March 2 2019 at 11:48 AM - English   

The one mentioned in External Trackers.
The update triggered me to read the article.

Comment 11 ir. Jan Gerrit Kootstra 2019-03-26 17:08:02 UTC
Hello Robert,


For a test I created 9 KVM guests on a KVM host that have some issues.
Now I see a Executive report.
Results are uploaded to RH Case https://access.redhat.com/support/cases/#/case/02320269


Regards,


Jan Gerrit

Comment 13 Rob Williams 2019-06-12 17:18:45 UTC
With the move of Insights to cloud.redhat.com which was launched early May and announced at Red Hat Summit, the executive reporting functionality of Insights has been temporarily removed as we re-evaluate our customer's reporting use-cases and aim to refactor our implementation to be targeted to a broader audience and multiple personas. The team is currently in it's user research phase if interested in help driving the design of future current and historical reporting needs in applications like Insights and Cloud Management Services for RHEL which is being tracked at the following BZ:

[RFE] Implementation of executive level or historical reporting for Red Hat Insights
https://bugzilla.redhat.com/show_bug.cgi?id=1705745.

Since this initial BZ was created for the original reporting functionality, it is no longer applicable and I will be moving this BZ towards its closure.


Note You need to log in before you can comment on or make changes to this bug.