Bug 1663323 - [DOC BUG] Samba servers with Active Directory can NOT use SSSD with Samba 4.8+
Summary: [DOC BUG] Samba servers with Active Directory can NOT use SSSD with Samba 4.8+
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-System_Administrators_Guide   
(Show other bugs)
Version: 7.5
Hardware: x86_64 Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Marc Muehlfeld
QA Contact: Leos Pol
Marc Muehlfeld
URL:
Whiteboard:
Keywords: Documentation, EasyFix
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-03 20:09 UTC by Jo Vilicic
Modified: 2019-01-07 07:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2019-01-07 07:14:15 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jo Vilicic 2019-01-03 20:09:39 UTC
Document URL: 
https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/system_administrators_guide/ch-file_and_print_servers#setting_up_samba_as_a_domain_member


Section Number and Name: 
"16.1.5. Setting up Samba as a Domain Member"


Describe the issue: 
With Samba 4.8+, we cannot use SSSD at all for joining a Samba server to an Active Directory environment.  This documentation affirms "use Winbind to join", but it does not make any mention of SSSD, which is a much more popular option for our customers.


Suggestions for improvement: 
Since Red Hat has been recommending using SSSD over Winbind for integrating to Active Directory, we would suggest adding an Alert box explaining that using Winbind is mandatory, and must be used in place of SSSD (the much more common, and otherwise recommended option).  We're suggesting this because we're having to convince customers to switch from their current configuration using SSSD over to a Winbind configuration.


Additional information: 
The following bug discusses the necessity for Winbind running with Samba 4.8+:
   "Bug 1624661 - Samba with security is set to ads fails to start after upgrade from 4.7.1-6 to 4.7.1-9."
   https://bugzilla.redhat.com/show_bug.cgi?id=1624661

Comment 2 Marc Muehlfeld 2019-01-04 10:57:23 UTC
We already have an <important> admonition about this:
https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/system_administrators_guide/ch-file_and_print_servers#the_samba_services
(under "Winbindd").

> Red Hat only supports running Samba as a server with the winbindd service to
> provide domain users and groups to the local system. Due to certain limitations,
> such as missing Windows access control list (ACL) support and NT LAN Manager (NTLM)
> fallback, the System Security Services Daemon (SSSD) is not supported.

Is this sufficient?

Comment 3 Jo Vilicic 2019-01-04 23:08:13 UTC
Yes, thank you.

We were thinking about a message possibly saying "SSSD is no longer supported" to address the cases where we're having to suggest changing a previously-working configuration, but we suppose that's not necessary.


Note You need to log in before you can comment on or make changes to this bug.