Bug 1663400 - the open file dialog of gimp causes total freeze
Summary: the open file dialog of gimp causes total freeze
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gimp
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-04 08:10 UTC by Dimitris
Modified: 2019-10-22 04:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-22 04:47:10 UTC


Attachments (Terms of Use)

Description Dimitris 2019-01-04 08:10:48 UTC
Description of problem:

I installed Fedora 29 (cinnamon spin) on 3 different systems (one at home, two for work). They ALL exhibit the following problem.

Once I click on the "open" button of the gimp file-open dialog, the system freezes (X total freeze).

Thus, gimp is unusable and can't open files via that method, but drag-drop seems to work.


Version-Release number of selected component (if applicable):

gimp-2.10.8-5.fc29.x86_64


How reproducible:

Always


Steps to Reproduce:
1. dnf install gimp
2. run gimp
3. File->Open
4. select a file and click on the Open button


Actual results:

Total X freeze.


Expected results:

No freeze?


Additional info:

Sometimes I can CTRL-ALT-F2 and drop to a console, but I can't do much from there. I tried killing cinnamon and a few other tricks but none worked, eventually I need to reboot.

I am using the cinnamon spin for all 3 installations.

All 3 systems are quite different hardware-wise, one uses an integrated Intel chipset (Intel 630 with nouvue) while another uses an AMD chipset (Radeon 580 amdgpu), the third has something much older.

Thank you.

Comment 1 Josef Ridky 2019-08-20 13:25:07 UTC
Thanks for reporting the issue.

I have tested it on F29 Cinnamon with gimp-2.10.12-2 and no freeze was detected.

Can you try to update your gimp and let me know, if the issue persists?

Comment 2 Dimitris 2019-10-22 04:47:10 UTC
Too late. I've moved to Fedora 30, which does not have this problem.


Note You need to log in before you can comment on or make changes to this bug.