Bug 166348 - Corrupt ToDos in Jpilot
Corrupt ToDos in Jpilot
Product: Fedora
Classification: Fedora
Component: jpilot (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Depends On:
  Show dependency treegraph
Reported: 2005-08-19 13:07 EDT by Pete Toscano
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-23 03:49:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Pete Toscano 2005-08-19 13:07:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050719 Epiphany/1.6.5

Description of problem:
Whenever I do a sync between my T3 and jpilot on FC4, I get corrupted ToDo entries.  These entries have unprintable characters, way off due dates, and invalid priorities.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Hit the hotsync button on the T3.
2. Press the hotsync button in Jpilot.
3. Enjoy the corrupted goodness.

Actual Results:  I submitted to bugzilla.  :)  Seriously though, I tried a few times to see if that changed anything.  The corrupted entries don't wind up back in the T3 and if I add a todo item via jpilot, it seems ok on the T3.

Expected Results:  I expected my ToDo entries to be uncorrupted in jpilot.  This worked fine in FC[1-3].

Additional info:
Comment 1 Pete Toscano 2005-08-22 06:57:16 EDT
I also noticed that none of my calendar entries are shown either.
Comment 2 Ivana Varekova 2005-08-23 05:06:27 EDT
could you please test the latest devel jpilot (jpilot-0.99.8-0.pre10.2)?
Thank you.
Ivana Varekova
Comment 3 Pete Toscano 2005-09-08 12:18:13 EDT
I have not tried the latest jpilot devel -- too many other dependencies pulled
in from the development repo -- but I think I found the source of the problem.  

I use GNU keyring a lot and usually keep a copy of jpilot running with that
plugin open.  Every-so-often, when I want to sync or do other PIM-related
activities, I open another jpilot process and go about my business.  If I sync,
I sync from this second process. (I have to re-authenticate to the keyring
plugin if I sync from that process.  This is why I use two processes vs just
that one.)  Once the sync is done, there are usually some freaky todo entries
(with invalid priority levels, blank descriptions, etc.) and I cannot see my cal
entries.  If I don't open that second jpilot process and sync from that first
one, everything seems to work fine.

The way I use jpilot worked just fine in FC3, but seems to cause some data
corruption in the FC4 version.

Comment 4 Ivana Varekova 2005-09-09 05:10:38 EDT
could you try to install the last jpilot (jpilot-0.99.8-0.pre10.1) and
pilot-link (pilot-link-0.12.0-0.pre4.1), you can use src.rpm
http://people.redhat.com/varekova/jpilot-0.99.8-0.pre10.1.src.rpm) and build
this packages yourself. This is the last version, I can't test this problem
myself, but this version fixes a lot of problems. If there is any problem,
please add comment.
Thank you,
Comment 5 Pete Toscano 2005-09-12 08:09:26 EDT
These packages seem to fix the concurrent access problems I've been seeing.
Comment 6 Ivana Varekova 2005-09-23 03:49:24 EDT
This bug is fixed in the last fc4 version (jpilot-0.99.8-0.pre10.fc4.1).

Note You need to log in before you can comment on or make changes to this bug.