Bug 166360 - SGI Prism systems crash early in the kernel without tioca fix
Summary: SGI Prism systems crash early in the kernel without tioca fix
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Prarit Bhargava
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: fedora-ia64
TreeView+ depends on / blocked
 
Reported: 2005-08-19 19:06 UTC by erikj
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-30 16:30:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description erikj 2005-08-19 19:06:26 UTC
Without this patch:

http://marc.theaimsgroup.com/?l=linux-ia64&m=112300257718539&w=2

A prism crashes early in the boot messages.  I'm assigning this to you Prarit
since you posted the LKML thing.  I'm just trying to avoid dropping the ball.
If you have another bug on this that I missed or think it's stupid to have this
open, just close it.

When I added this patch to the patch list for the 2.6.12-1.1492_FC5 kernel,
the problem went away.  The patch applies cleanly at the end of the patch
list for the 1492 RPM.  

I didn't see any follow-up to your LKML post.  I assume we're just waiting
for them to pull it in.

Comment 1 Warren Togami 2005-08-20 00:19:58 UTC
ia64 is not an officially supported architecture of Fedora, but if you can get
the fix for this into the upstream kernel.org kernel, then it will be quickly
into the FC5 kernel as we pull from git snapshots regularly.

Comment 2 Prarit Bhargava 2005-08-30 15:58:17 UTC
Erik,

It looks like this patch was ported into the latest FC5.

When you get a chance, would you mind trying it again?  It works on my PRISM
here in Westford.

(You'll still fail due to the missing LSI driver, but you shouldn't oops until
after the initrd is expanded)

Thanks,

P.

Comment 3 erikj 2005-08-30 16:30:27 UTC
Using the latest boot.img to launch the installer...  The installer actually
starts up, which means I see this as fixed as well since we'd die before the
kernel fully started before.

(The installer hits a python error but that's a different issue).

Closing.


Note You need to log in before you can comment on or make changes to this bug.