Bug 1663680 - dnf doesn't resolve dependencies for vlc: missing libs (jack-audio-connection-kit)
Summary: dnf doesn't resolve dependencies for vlc: missing libs (jack-audio-connection...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Carla   
(Show other bugs)
Version: 29
Hardware: x86_64 Linux
unspecified
low
Target Milestone: ---
Assignee: MartinKG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened, Triaged
: 1664665 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-06 13:58 UTC by lukasas@poczta.fm
Modified: 2019-01-09 22:16 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2019-01-08 17:46:16 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dnf.log (877.22 KB, text/plain)
2019-01-07 21:13 UTC, lukasas@poczta.fm
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
RPM Fusion 5131 None None None 2019-01-06 13:58 UTC

Description lukasas@poczta.fm 2019-01-06 13:58:08 UTC
This was reported to rpmfusion bugzilla yesterday: https://bugzilla.rpmfusion.org/show_bug.cgi?id=5131

Looks like rpms packages are fine but dnf doesn't resolve dependencies properly(?)


Description of problem:

Clean new installation of Fedora 29, I don't have many packages/dependencies so that's probably why I stumbled upon this.

Running `vlc -v` results:

[00005593a1db6590] main libvlc warning: cannot load module `/usr/lib64/vlc/plugins/audio_output/libjack_plugin.so' (libjack.so.0: cannot open shared object file: No such file or directory)
[00005593a1db6590] main libvlc warning: cannot load module `/usr/lib64/vlc/plugins/access/libaccess_jack_plugin.so' (libjack.so.0: cannot open shared object file: No such file or directory)
[00005593a1db6590] main libvlc warning: cannot load module `/usr/lib64/vlc/plugins/codec/libfluidsynth_plugin.so' (libjack.so.0: cannot open shared object file: No such file or directory)

Solved by: `dnf install jack-audio-connection-kit`


Version-Release number of selected component (if applicable):

# rpm -q libsolv hawkey dnf
libsolv-0.7.2-1.fc29.x86_64
package hawkey is not installed
dnf-4.0.9-2.fc29.noarch


Steps to Reproduce:

1. enable rpmfusion
2. dnf install vlc
3. vlc segfaults

Actual results:

libjack.so.0: cannot open shared object file: No such file or directory


Expected results:

jack-audio-connection-kit installed as a dependency for vlc


Additional info:
Is hawkey supposed to be installed by default? I don't have it on my system.

Comment 1 Marek Blaha 2019-01-07 08:02:51 UTC
Hi, I tried on fresh Fedora 29 to do following:
1. enable rpmfusion-free repository
2. # dnf install vlc
Dnf reported that jack-audio-connection-kit would be installed as a dependency, so everything looks all right.

Are you able to provide dnf.log from installing vlc?

Comment 2 lukasas@poczta.fm 2019-01-07 21:13 UTC
Created attachment 1519076 [details]
dnf.log

Comment 3 lukasas@poczta.fm 2019-01-07 21:17:32 UTC
Added dnf.log file. Be mindful that I interrupted first vlc installation (ctrl+c) when dnf asked yes/no, scroll log lower for the real one. Not connected with the issue. I was doing some other system maintenance and didn't want to wait for vlc installation.

Comment 4 Marek Blaha 2019-01-08 06:35:13 UTC
Thanks, now I think I see the problem:

$ dnf repoquery --requires vlc | grep jack
libjack.so.0
libjack.so.0()(64bit)

So vlc does not require literally jack-audio-connection-kit, but the libjack.so.0.

$ dnf provides 'libjack.so.0'
Carla-2.0.0-0.5.20181225git2f3a442.fc29.i686 : Audio plugin host
Repo        : updates
Matched from:
Provide    : libjack.so.0

jack-audio-connection-kit-1.9.12-6.fc29.i686 : The Jack Audio Connection Kit
Repo        : fedora
Matched from:
Provide    : libjack.so.0

There are two packages providing requested 'libjack.so.0' - jack-audio-connection-kit and Carla. According to your dnf.log, solver had chosen the Carla package as a provider of libjack.so.0, which is perfectly valid solution. If vlc is not satisfied with Carla, it should probably request directly jack-audio-connection-kit package instead. I would reassign this bug to the vlc component, but since vlc is not part of Fedora, I'm closing it here as "not a bug". You can add link to this bug to your vlc bug on rpmfusion bugzilla. Hope it will help. If you are not satisfied with the explanation, please feel free to reopen the bug.

Comment 5 lukasas@poczta.fm 2019-01-08 17:45:55 UTC
Thanks Marek for the great answer!
I'll link this bug report to the rpmfusion one.

Comment 6 Nicolas Chauvet (kwizart) 2019-01-08 18:31:33 UTC
Carla should in for no reason provide libjack.so.0 at all.
Seems like it's been fixed in fedora updates-testing.

Comment 7 Nicolas Chauvet (kwizart) 2019-01-09 22:16:40 UTC
*** Bug 1664665 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.